summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-01-14 11:22:26 +0100
committerJohannes Huber <johu@gentoo.org>2017-01-14 11:22:26 +0100
commit7e450180e2f411f6d1b3eb252f28ea819b564bb0 (patch)
treec37bea2de8f258a9978e521feb0cdea5f5b3894f /kde-frameworks/kcrash/kcrash-5.30.0.ebuild
parentdev-libs/appstream: New package (diff)
downloadgentoo-7e450180e2f411f6d1b3eb252f28ea819b564bb0.tar.gz
gentoo-7e450180e2f411f6d1b3eb252f28ea819b564bb0.tar.bz2
gentoo-7e450180e2f411f6d1b3eb252f28ea819b564bb0.zip
kde-frameworks: Version bump KDE Frameworks 5.30.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-frameworks/kcrash/kcrash-5.30.0.ebuild')
-rw-r--r--kde-frameworks/kcrash/kcrash-5.30.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/kde-frameworks/kcrash/kcrash-5.30.0.ebuild b/kde-frameworks/kcrash/kcrash-5.30.0.ebuild
new file mode 100644
index 000000000000..1b478a892966
--- /dev/null
+++ b/kde-frameworks/kcrash/kcrash-5.30.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for intercepting and handling application crashes"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="nls"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ nls? ( $(add_qt_dep linguist-tools) )
+ test? ( $(add_qt_dep qtwidgets) )
+"