summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-09 01:42:07 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-09 14:09:37 +0200
commit24a531e2e4e33dd79ec72fa3d00a509c648f9179 (patch)
tree245198e2c340d1be87a772a698840f91d272378c /kde-frameworks/kcrash/kcrash-5.82.0.ebuild
parentkde-frameworks/kcontacts: 5.82.0 version bump (diff)
downloadgentoo-24a531e2e4e33dd79ec72fa3d00a509c648f9179.tar.gz
gentoo-24a531e2e4e33dd79ec72fa3d00a509c648f9179.tar.bz2
gentoo-24a531e2e4e33dd79ec72fa3d00a509c648f9179.zip
kde-frameworks/kcrash: 5.82.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kcrash/kcrash-5.82.0.ebuild')
-rw-r--r--kde-frameworks/kcrash/kcrash-5.82.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-frameworks/kcrash/kcrash-5.82.0.ebuild b/kde-frameworks/kcrash/kcrash-5.82.0.ebuild
new file mode 100644
index 000000000000..c9026f018d6a
--- /dev/null
+++ b/kde-frameworks/kcrash/kcrash-5.82.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for intercepting and handling application crashes"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ test? ( >=dev-qt/qtwidgets-${QTMIN}:5 )
+"