summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-09-12 15:29:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-09-12 22:32:55 +0200
commitd94e4d403a72074c80a12e088cfb2ed055669d76 (patch)
treeca9547cd2515508030ce07f6ac893e7fdd5c4b5d /kde-frameworks/kdeclarative
parentkde-frameworks/kirigami: Drop old (diff)
downloadgentoo-d94e4d403a72074c80a12e088cfb2ed055669d76.tar.gz
gentoo-d94e4d403a72074c80a12e088cfb2ed055669d76.tar.bz2
gentoo-d94e4d403a72074c80a12e088cfb2ed055669d76.zip
kde-frameworks: Drop KDE Frameworks 5.34.0
Except ECM which is required for hppa. Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'kde-frameworks/kdeclarative')
-rw-r--r--kde-frameworks/kdeclarative/Manifest1
-rw-r--r--kde-frameworks/kdeclarative/files/kdeclarative-5.34.0-memleak.patch73
-rw-r--r--kde-frameworks/kdeclarative/kdeclarative-5.34.0-r1.ebuild34
-rw-r--r--kde-frameworks/kdeclarative/kdeclarative-5.34.0.ebuild32
4 files changed, 0 insertions, 140 deletions
diff --git a/kde-frameworks/kdeclarative/Manifest b/kde-frameworks/kdeclarative/Manifest
index 705a7a93c740..b95456584780 100644
--- a/kde-frameworks/kdeclarative/Manifest
+++ b/kde-frameworks/kdeclarative/Manifest
@@ -1,3 +1,2 @@
-DIST kdeclarative-5.34.0.tar.xz 169124 SHA256 e29faa82dd82434add4aa6c3d57f11c892e5a21905cd46d3e7fb8761ae18d2d5 SHA512 1de23d880b370d164ea80a0a2cf590bfb0f42b550fe0b39ee34b155d1e59c346bca91a5775bba35067ce3d83d373cbce4938992da3f0d36145c1f69b05ef7ba6 WHIRLPOOL 7a803f7bd9285889e83a0d84e5e85e3fb52ded1817b2a41ba0ab9f149ea217cf39b801d2d9099e9357294adb264ce0985f04b0d0c87bf9f854460ad227b21b5f
DIST kdeclarative-5.37.0.tar.xz 169808 SHA256 f2bdd7e1c6d0f39b4e1573b11078317e9ec72803c63ce4acc4d7de26aa2150c7 SHA512 903df965d34ae3bcd0e4c84d1821843bb20ba7e90c276b4b10b47f3455fbace1b5dba31597124757fd93990baf95a5cf8fd7453eae9711545475ad1997dda06e WHIRLPOOL 6bb6de7490e9b2697a49d65f526e662f21639f80bbe1f8f363571174c82795756386a904d428404b0d021b6438e37bc3389181c463fc1e14541abb78d085b6a2
DIST kdeclarative-5.38.0.tar.xz 169840 SHA256 8b38aba552f06596a47d52d364f7a21784e741cfb0c7f23815f1cf067fd7c6a4 SHA512 72ea8b2f17792e3075800de93882c0a0b03732121eef43ab38285c0d1988e148e079f40dd6d4fc8afef75bda47f2e02a3ac84b9546c6a6991b10aade1dbcb978 WHIRLPOOL ebc3d86fa47b8b95239c05262f2d10f2b18a505b4147cb33cb74d929acc0b1b1d4dd7cfeff6d4b6e5083ffe6d1d49377bd70e82f596973e6a94ec1937fb1a875
diff --git a/kde-frameworks/kdeclarative/files/kdeclarative-5.34.0-memleak.patch b/kde-frameworks/kdeclarative/files/kdeclarative-5.34.0-memleak.patch
deleted file mode 100644
index 43fdb8a4bf66..000000000000
--- a/kde-frameworks/kdeclarative/files/kdeclarative-5.34.0-memleak.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-From 695f24fb522a5ae6fe2530cbd72d3966b234b025 Mon Sep 17 00:00:00 2001
-From: David Edmundson <kde@davidedmundson.co.uk>
-Date: Wed, 31 May 2017 10:08:25 +0100
-Subject: [PATCH] Don't leak MimeData object
-
-Summary:
-A DeclarativeDropArea creates a new DeclarativeDragDropEvent on every
-enter/move/leave event.
-
-The getter method for the mimeData property creates a new MimeData
-QObject wrapper, which then leaks.
-
-Use of the mimeData object outside of the event shouldn't be expected to
-work, and a quick grep couldn't find any usage.
-
-BUG: 380270
-
-Test Plan: Dragged some things
-
-Reviewers: #plasma, mart, hein
-
-Reviewed By: #plasma, mart, hein
-
-Subscribers: hein, plasma-devel, #frameworks
-
-Tags: #plasma, #frameworks
-
-Differential Revision: https://phabricator.kde.org/D6017
----
- src/qmlcontrols/draganddrop/DeclarativeDragDropEvent.cpp | 4 ++--
- src/qmlcontrols/draganddrop/DeclarativeDragDropEvent.h | 5 ++---
- 2 files changed, 4 insertions(+), 5 deletions(-)
-
-diff --git a/src/qmlcontrols/draganddrop/DeclarativeDragDropEvent.cpp b/src/qmlcontrols/draganddrop/DeclarativeDragDropEvent.cpp
-index 5c1b0e3..a75f85f 100644
---- a/src/qmlcontrols/draganddrop/DeclarativeDragDropEvent.cpp
-+++ b/src/qmlcontrols/draganddrop/DeclarativeDragDropEvent.cpp
-@@ -65,7 +65,7 @@ DeclarativeMimeData* DeclarativeDragDropEvent::mimeData()
- if (!m_data && m_event) {
- // TODO This should be using MimeDataWrapper eventually, although this is an API break,
- // so will need to be done carefully.
-- m_data = new DeclarativeMimeData(m_event->mimeData());
-+ m_data.reset(new DeclarativeMimeData(m_event->mimeData()));
- }
-- return m_data;
-+ return m_data.data();
- }
-diff --git a/src/qmlcontrols/draganddrop/DeclarativeDragDropEvent.h b/src/qmlcontrols/draganddrop/DeclarativeDragDropEvent.h
-index 3fd846d..b35568a 100644
---- a/src/qmlcontrols/draganddrop/DeclarativeDragDropEvent.h
-+++ b/src/qmlcontrols/draganddrop/DeclarativeDragDropEvent.h
-@@ -26,8 +26,7 @@
-
- #include <QObject>
- #include "DeclarativeDropArea.h"
--
--class DeclarativeMimeData;
-+#include "DeclarativeMimeData.h"
-
- class DeclarativeDragDropEvent : public QObject
- {
-@@ -115,7 +114,7 @@ private:
- int m_y;
- Qt::MouseButtons m_buttons;
- Qt::KeyboardModifiers m_modifiers;
-- DeclarativeMimeData* m_data;
-+ QScopedPointer<DeclarativeMimeData> m_data;
- QDropEvent* m_event;
- };
-
---
-2.13.0
-
diff --git a/kde-frameworks/kdeclarative/kdeclarative-5.34.0-r1.ebuild b/kde-frameworks/kdeclarative/kdeclarative-5.34.0-r1.ebuild
deleted file mode 100644
index da3138effd9e..000000000000
--- a/kde-frameworks/kdeclarative/kdeclarative-5.34.0-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-KDE_TEST="false"
-inherit kde5
-
-DESCRIPTION="Framework providing integration of QML and KDE work spaces"
-LICENSE="LGPL-2+"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-# drop qtdeclarative subslot operator when QT_MINIMAL >= 5.8.0
-DEPEND="
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep kglobalaccel)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep kiconthemes)
- $(add_frameworks_dep kio)
- $(add_frameworks_dep kpackage)
- $(add_frameworks_dep kservice)
- $(add_frameworks_dep kwidgetsaddons)
- $(add_frameworks_dep kwindowsystem)
- $(add_qt_dep qtdeclarative '' '' '5=')
- $(add_qt_dep qtgui)
- $(add_qt_dep qtnetwork)
- $(add_qt_dep qtwidgets)
- media-libs/libepoxy
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/${P}-memleak.patch" )
diff --git a/kde-frameworks/kdeclarative/kdeclarative-5.34.0.ebuild b/kde-frameworks/kdeclarative/kdeclarative-5.34.0.ebuild
deleted file mode 100644
index a5e983b5dbdb..000000000000
--- a/kde-frameworks/kdeclarative/kdeclarative-5.34.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-KDE_TEST="false"
-inherit kde5
-
-DESCRIPTION="Framework providing integration of QML and KDE work spaces"
-LICENSE="LGPL-2+"
-KEYWORDS="amd64 ~arm x86"
-IUSE=""
-
-# drop qtdeclarative subslot operator when QT_MINIMAL >= 5.8.0
-DEPEND="
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep kglobalaccel)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep kiconthemes)
- $(add_frameworks_dep kio)
- $(add_frameworks_dep kpackage)
- $(add_frameworks_dep kservice)
- $(add_frameworks_dep kwidgetsaddons)
- $(add_frameworks_dep kwindowsystem)
- $(add_qt_dep qtdeclarative '' '' '5=')
- $(add_qt_dep qtgui)
- $(add_qt_dep qtnetwork)
- $(add_qt_dep qtwidgets)
- media-libs/libepoxy
-"
-RDEPEND="${DEPEND}"