summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-11-12 10:27:51 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-11-12 10:43:15 +0100
commitae2630502e1ac59062e2fb88d5cb318914d89005 (patch)
tree929d466c76645ea9a5251d8faf2fa48234358b43 /kde-frameworks/kdesu/kdesu-5.112.0.ebuild
parentkde-frameworks/kded: 5.112.0 version bump (diff)
downloadgentoo-ae2630502e1ac59062e2fb88d5cb318914d89005.tar.gz
gentoo-ae2630502e1ac59062e2fb88d5cb318914d89005.tar.bz2
gentoo-ae2630502e1ac59062e2fb88d5cb318914d89005.zip
kde-frameworks/kdesu: 5.112.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kdesu/kdesu-5.112.0.ebuild')
-rw-r--r--kde-frameworks/kdesu/kdesu-5.112.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-frameworks/kdesu/kdesu-5.112.0.ebuild b/kde-frameworks/kdesu/kdesu-5.112.0.ebuild
new file mode 100644
index 000000000000..d5ebea58648d
--- /dev/null
+++ b/kde-frameworks/kdesu/kdesu-5.112.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-2)
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework to handle super user actions"
+
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="X"
+
+RDEPEND="
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kpty-${PVCUT}*:5
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package X X11)
+ )
+
+ ecm_src_configure
+}