summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-12 13:48:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-12 14:37:41 +0200
commitc5acb9e0ce86d466997f939439a63c9488fadcdb (patch)
treec7c4dcbc0e6f6c533193b3b2879b06603b1a1f30 /kde-frameworks/kdesu/kdesu-5.74.0.ebuild
parentkde-frameworks/kded: 5.74.0 version bump (diff)
downloadgentoo-c5acb9e0ce86d466997f939439a63c9488fadcdb.tar.gz
gentoo-c5acb9e0ce86d466997f939439a63c9488fadcdb.tar.bz2
gentoo-c5acb9e0ce86d466997f939439a63c9488fadcdb.zip
kde-frameworks/kdesu: 5.74.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kdesu/kdesu-5.74.0.ebuild')
-rw-r--r--kde-frameworks/kdesu/kdesu-5.74.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-frameworks/kdesu/kdesu-5.74.0.ebuild b/kde-frameworks/kdesu/kdesu-5.74.0.ebuild
new file mode 100644
index 000000000000..fc8d98e4b310
--- /dev/null
+++ b/kde-frameworks/kdesu/kdesu-5.74.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-2)
+inherit ecm kde.org
+
+DESCRIPTION="Framework to handle super user actions"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="X"
+
+RDEPEND="
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kpty-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package X X11)
+ )
+
+ ecm_src_configure
+}