summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-05-13 18:35:58 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-05-13 18:55:16 +0200
commitf87ed0f846fb807182dd39a6ad260eb809f337fc (patch)
tree352cff864a02b759899fc88aafe0424319aeacb3 /kde-frameworks/kdnssd/kdnssd-5.106.0.ebuild
parentkde-frameworks/kdbusaddons: 5.106.0 version bump (diff)
downloadgentoo-f87ed0f846fb807182dd39a6ad260eb809f337fc.tar.gz
gentoo-f87ed0f846fb807182dd39a6ad260eb809f337fc.tar.bz2
gentoo-f87ed0f846fb807182dd39a6ad260eb809f337fc.zip
kde-frameworks/kdnssd: 5.106.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kdnssd/kdnssd-5.106.0.ebuild')
-rw-r--r--kde-frameworks/kdnssd/kdnssd-5.106.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-frameworks/kdnssd/kdnssd-5.106.0.ebuild b/kde-frameworks/kdnssd/kdnssd-5.106.0.ebuild
new file mode 100644
index 000000000000..0e03694f873a
--- /dev/null
+++ b/kde-frameworks/kdnssd/kdnssd-5.106.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QTMIN=5.15.5
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for network service discovery using Zeroconf"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="zeroconf"
+
+DEPEND="
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ zeroconf? (
+ >=dev-qt/qtdbus-${QTMIN}:5
+ net-dns/avahi[mdnsresponder-compat]
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=">=dev-qt/linguist-tools-${QTMIN}:5"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package zeroconf Avahi)
+ )
+ use zeroconf || mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_DNSSD=ON )
+
+ ecm_src_configure
+}