summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-11-14 13:36:42 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-11-14 15:16:39 +0100
commit70eeba66fd5a0f997f4a968aa924ad84a0f3fb94 (patch)
treee553e22028947d7bfc6f93fa6149443474f50e7c /kde-frameworks/kdoctools
parentkde-frameworks/kcrash: 5.100.0 version bump (diff)
downloadgentoo-70eeba66fd5a0f997f4a968aa924ad84a0f3fb94.tar.gz
gentoo-70eeba66fd5a0f997f4a968aa924ad84a0f3fb94.tar.bz2
gentoo-70eeba66fd5a0f997f4a968aa924ad84a0f3fb94.zip
kde-frameworks/kdoctools: 5.100.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kdoctools')
-rw-r--r--kde-frameworks/kdoctools/Manifest1
-rw-r--r--kde-frameworks/kdoctools/kdoctools-5.100.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-frameworks/kdoctools/Manifest b/kde-frameworks/kdoctools/Manifest
index ffc4510c74a5..d66002cae0b7 100644
--- a/kde-frameworks/kdoctools/Manifest
+++ b/kde-frameworks/kdoctools/Manifest
@@ -1,2 +1,3 @@
+DIST kdoctools-5.100.0.tar.xz 462844 BLAKE2B 52e88f5f061e4eec94c60f6cf0575fad63a2daad8a16910ae96e7a81f4c52a6096a717ee1d73e357ada3777b0217202149357668819877dd9ca6fe2c322f5306 SHA512 4a928b3cca81fb8bb52c468b68fabfa1fb4b740af0ac10cba35cc421df1f887c83104bfe4a7ac0f6f387dc9000f1d9927d484fdc8ca5003de5e5186f8a2579b4
DIST kdoctools-5.96.0.tar.xz 440328 BLAKE2B ed7672eacd056ffc81ed334313f8beaf45dfd1efbd96721ae5b2f6aa7c734dd4bf7b2f304c1ffefa4abd0a88c4e950eed6f736df61808a691d979589b7e0157c SHA512 cf0dea4b872513a1b79db6b4c7b58b56e5c73267cd89668e843ea10ecb3c544614bb22d1af9739436d192805a8f643d9e51374034f529c6be4fb518741f6eaa7
DIST kdoctools-5.99.0.tar.xz 440896 BLAKE2B 78aa5464b1a6242dc994c3ca227c6f67a7a1443da1bc4d280854c114da64e5a8d83022681adc044921e2a35db502d3e8108aedd6c2fd047575a04c1b380fb853 SHA512 c6e2f8d9863be278935db8ef69622464d870629a9dd57de89b51ac2b19bea1b658ec96b89396474cf6a748ebaaa95869b9ff068a2d085332b60b62eb77ef05ab
diff --git a/kde-frameworks/kdoctools/kdoctools-5.100.0.ebuild b/kde-frameworks/kdoctools/kdoctools-5.100.0.ebuild
new file mode 100644
index 000000000000..fe72dddcecef
--- /dev/null
+++ b/kde-frameworks/kdoctools/kdoctools-5.100.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Tools to generate documentation in various formats from DocBook files"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="nls"
+
+BDEPEND="
+ dev-lang/perl
+ dev-perl/URI
+ nls? ( >=kde-frameworks/ki18n-${PVCUT}:5 )
+"
+DEPEND="
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets
+ app-text/sgml-common
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ =kde-frameworks/karchive-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-5.54.0-gentoo-docbundledir.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package nls KF5I18n)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # bug 665622
+ local myctestargs=(
+ -E "(kdoctools_install)"
+ )
+
+ ecm_src_test
+}