summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-10-08 19:59:02 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-10-10 10:14:23 +0200
commitb758de7594234e3b5091d24cce4eb69a71be68cc (patch)
treebc122839583772c4ac16d25b884d23e6f25b95b7 /kde-frameworks/kdoctools
parentkde-frameworks/kcrash: 5.99.0 version bump (diff)
downloadgentoo-b758de7594234e3b5091d24cce4eb69a71be68cc.tar.gz
gentoo-b758de7594234e3b5091d24cce4eb69a71be68cc.tar.bz2
gentoo-b758de7594234e3b5091d24cce4eb69a71be68cc.zip
kde-frameworks/kdoctools: 5.99.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kdoctools')
-rw-r--r--kde-frameworks/kdoctools/Manifest1
-rw-r--r--kde-frameworks/kdoctools/kdoctools-5.99.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-frameworks/kdoctools/Manifest b/kde-frameworks/kdoctools/Manifest
index 3484d619c6f6..34be317deb2f 100644
--- a/kde-frameworks/kdoctools/Manifest
+++ b/kde-frameworks/kdoctools/Manifest
@@ -1,2 +1,3 @@
DIST kdoctools-5.96.0.tar.xz 440328 BLAKE2B ed7672eacd056ffc81ed334313f8beaf45dfd1efbd96721ae5b2f6aa7c734dd4bf7b2f304c1ffefa4abd0a88c4e950eed6f736df61808a691d979589b7e0157c SHA512 cf0dea4b872513a1b79db6b4c7b58b56e5c73267cd89668e843ea10ecb3c544614bb22d1af9739436d192805a8f643d9e51374034f529c6be4fb518741f6eaa7
DIST kdoctools-5.98.0.tar.xz 440760 BLAKE2B f366557773c48a6b54fad1fb1ed6daa6702f607412eab4aa32b9a76132393fa74e38fd11e3877399b9664f59fc1108232785832a0bfc02dc586fa60fe6e8d8aa SHA512 5ebc7a012a2cdd68e5b9e39616f970f9508cca149653f8a2f3d9867228136b13a041e37d1163b977e785a846899090558b0ae69ae073ebdb578584f73fd4e3f2
+DIST kdoctools-5.99.0.tar.xz 440896 BLAKE2B 78aa5464b1a6242dc994c3ca227c6f67a7a1443da1bc4d280854c114da64e5a8d83022681adc044921e2a35db502d3e8108aedd6c2fd047575a04c1b380fb853 SHA512 c6e2f8d9863be278935db8ef69622464d870629a9dd57de89b51ac2b19bea1b658ec96b89396474cf6a748ebaaa95869b9ff068a2d085332b60b62eb77ef05ab
diff --git a/kde-frameworks/kdoctools/kdoctools-5.99.0.ebuild b/kde-frameworks/kdoctools/kdoctools-5.99.0.ebuild
new file mode 100644
index 000000000000..fe72dddcecef
--- /dev/null
+++ b/kde-frameworks/kdoctools/kdoctools-5.99.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Tools to generate documentation in various formats from DocBook files"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="nls"
+
+BDEPEND="
+ dev-lang/perl
+ dev-perl/URI
+ nls? ( >=kde-frameworks/ki18n-${PVCUT}:5 )
+"
+DEPEND="
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets
+ app-text/sgml-common
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ =kde-frameworks/karchive-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-5.54.0-gentoo-docbundledir.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package nls KF5I18n)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # bug 665622
+ local myctestargs=(
+ -E "(kdoctools_install)"
+ )
+
+ ecm_src_test
+}