summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-07-09 13:26:07 +0200
committerJohannes Huber <johu@gentoo.org>2016-07-09 13:26:18 +0200
commit1efcf4a75fe009c2eac7b89c42e2b4b4b162834a (patch)
treea9d6dc56e66a8df4621208a6176b8ce8fd6f2b8a /kde-frameworks/ki18n/ki18n-5.24.0.ebuild
parentgnome-extra/cinnamon: Rebuilding with NM subslot bump will be needed when it'... (diff)
downloadgentoo-1efcf4a75fe009c2eac7b89c42e2b4b4b162834a.tar.gz
gentoo-1efcf4a75fe009c2eac7b89c42e2b4b4b162834a.tar.bz2
gentoo-1efcf4a75fe009c2eac7b89c42e2b4b4b162834a.zip
kde-frameworks: Version bump KDE Frameworks 5.24.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-frameworks/ki18n/ki18n-5.24.0.ebuild')
-rw-r--r--kde-frameworks/ki18n/ki18n-5.24.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-frameworks/ki18n/ki18n-5.24.0.ebuild b/kde-frameworks/ki18n/ki18n-5.24.0.ebuild
new file mode 100644
index 000000000000..246534034851
--- /dev/null
+++ b/kde-frameworks/ki18n/ki18n-5.24.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit kde5 python-single-r1
+
+DESCRIPTION="Framework based on Gettext for internationalizing user interface text"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(add_qt_dep qtscript)
+ sys-devel/gettext
+ virtual/libintl
+"
+DEPEND="${RDEPEND}
+ test? ( $(add_qt_dep qtconcurrent) )
+"
+
+pkg_setup() {
+ kde5_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ kde5_src_install
+ python_fix_shebang "${D}/usr/$(get_libdir)/cmake/KF5I18n/ts-pmap-compile.py"
+}