summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-08-12 10:13:37 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-08-13 23:25:51 +0200
commit1edaeb45f8c277a4086e56f4e7da0d4dddfa6c91 (patch)
tree559f69cc4565f7c59d4e7ac92cbab98a5fb86968 /kde-frameworks/kimageformats/kimageformats-5.37.0.ebuild
parentsys-kernel/gentoo-sources: Cleanup of the 4.12.X series (diff)
downloadgentoo-1edaeb45f8c277a4086e56f4e7da0d4dddfa6c91.tar.gz
gentoo-1edaeb45f8c277a4086e56f4e7da0d4dddfa6c91.tar.bz2
gentoo-1edaeb45f8c277a4086e56f4e7da0d4dddfa6c91.zip
kde-frameworks: Add KDE Frameworks 5.37
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'kde-frameworks/kimageformats/kimageformats-5.37.0.ebuild')
-rw-r--r--kde-frameworks/kimageformats/kimageformats-5.37.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/kimageformats/kimageformats-5.37.0.ebuild b/kde-frameworks/kimageformats/kimageformats-5.37.0.ebuild
new file mode 100644
index 000000000000..5cf085634aed
--- /dev/null
+++ b/kde-frameworks/kimageformats/kimageformats-5.37.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework providing additional format plugins for Qt's image I/O system"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="eps openexr"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_qt_dep qtgui)
+ eps? ( $(add_qt_dep qtprintsupport) )
+ openexr? (
+ media-libs/ilmbase:=
+ media-libs/openexr:=
+ )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( src/imageformats/AUTHORS )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package eps Qt5PrintSupport)
+ $(cmake-utils_use_find_package openexr OpenEXR)
+ )
+
+ kde5_src_configure
+}