summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-15 12:46:06 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-15 12:49:22 +0200
commitaace2cf1177ab92d31ede9aeb02118d409baa700 (patch)
tree8ee577c50da349096490a257f853784b7ee96153 /kde-frameworks/kio/kio-5.82.0-r1.ebuild
parentdev-vcs/stgit: QA: drop ${D} from src_compile() (diff)
downloadgentoo-aace2cf1177ab92d31ede9aeb02118d409baa700.tar.gz
gentoo-aace2cf1177ab92d31ede9aeb02118d409baa700.tar.bz2
gentoo-aace2cf1177ab92d31ede9aeb02118d409baa700.zip
kde-frameworks/kio: Upstream backport request for memleak fix
See also: https://mail.kde.org/pipermail/distributions/2021-May/000998.html KDE-bug: https://bugs.kde.org/show_bug.cgi?id=398908 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kio/kio-5.82.0-r1.ebuild')
-rw-r--r--kde-frameworks/kio/kio-5.82.0-r1.ebuild110
1 files changed, 110 insertions, 0 deletions
diff --git a/kde-frameworks/kio/kio-5.82.0-r1.ebuild b/kde-frameworks/kio/kio-5.82.0-r1.ebuild
new file mode 100644
index 000000000000..297ae2bbe4af
--- /dev/null
+++ b/kde-frameworks/kio/kio-5.82.0-r1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org xdg-utils
+
+DESCRIPTION="Framework providing transparent file and data management"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="acl +handbook kerberos +kwallet X"
+
+# tests hang
+RESTRICT+=" test"
+
+RDEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5[ssl]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ =kde-frameworks/kauth-${PVCUT}*:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kbookmarks-${PVCUT}*:5
+ =kde-frameworks/kcodecs-${PVCUT}*:5
+ =kde-frameworks/kcompletion-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kcrash-${PVCUT}*:5
+ =kde-frameworks/kdbusaddons-${PVCUT}*:5
+ =kde-frameworks/kguiaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kitemviews-${PVCUT}*:5
+ =kde-frameworks/kjobwidgets-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/ktextwidgets-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
+ =kde-frameworks/solid-${PVCUT}*:5
+ acl? (
+ sys-apps/attr
+ virtual/acl
+ )
+ handbook? ( =kde-frameworks/kdoctools-${PVCUT}*:5 )
+ kerberos? ( virtual/krb5 )
+ kwallet? ( =kde-frameworks/kwallet-${PVCUT}*:5 )
+ X? ( >=dev-qt/qtx11extras-${QTMIN}:5 )
+"
+DEPEND="${RDEPEND}
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ test? ( sys-libs/zlib )
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libX11
+ x11-libs/libXrender
+ )
+"
+PDEPEND="
+ >=kde-frameworks/kded-${PVCUT}:5
+"
+
+PATCHES=(
+ # pending https://invent.kde.org/frameworks/kio/-/merge_requests/426
+ "${FILESDIR}"/${PN}-5.81.0-fix-qtconcurrent-private-link.patch # bug 784971
+ # upstream backport request - see also KDE-bug 398908
+ "${FILESDIR}"/${P}-MimeTypeFinderJob-memleak-{1,2,3,4}.patch
+ # git master/KIO 5.83:
+ "${FILESDIR}"/${P}-no-useragent-kcm.patch
+ "${FILESDIR}"/${P}-no-cache-kcm.patch
+)
+
+src_prepare() {
+ ecm_src_prepare
+ rm -rf po/*/docs/kcontrol5/{cache,useragent} || die # superfluous docs
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package acl ACL)
+ $(cmake_use_find_package handbook KF5DocTools)
+ $(cmake_use_find_package kerberos GSSAPI)
+ $(cmake_use_find_package kwallet KF5Wallet)
+ $(cmake_use_find_package X X11)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ ecm_pkg_postrm
+ xdg_desktop_database_update
+}