summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-frameworks/kio
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-frameworks/kio')
-rw-r--r--kde-frameworks/kio/Manifest1
-rw-r--r--kde-frameworks/kio/files/kio-tests-optional.patch28
-rw-r--r--kde-frameworks/kio/kio-5.12.0.ebuild84
-rw-r--r--kde-frameworks/kio/metadata.xml5
4 files changed, 118 insertions, 0 deletions
diff --git a/kde-frameworks/kio/Manifest b/kde-frameworks/kio/Manifest
new file mode 100644
index 000000000000..9854e78cb702
--- /dev/null
+++ b/kde-frameworks/kio/Manifest
@@ -0,0 +1 @@
+DIST kio-5.12.0.tar.xz 2848908 SHA256 fcd81e8ddeee72ac3b4802d974b5591985b6d2943b028953093507a5fcb3328d SHA512 b4433b11eb2aa806dec9d907833e0079a5ead2dd1c4942e909e8b3d7eba52b59fcabe32a64e42dcfc364b4e23ff12bf5128bb99085ad73823fc8bfa3cbd3b04c WHIRLPOOL fe3dbe7a7de6eec4aa6f6ad812c11fd423261a1dac7b7ea49fe4f1c8c5c07de4e31ab042893d25426b52ca952759307acbb81864e6a9cb40f9cd7ccd175f983e
diff --git a/kde-frameworks/kio/files/kio-tests-optional.patch b/kde-frameworks/kio/files/kio-tests-optional.patch
new file mode 100644
index 000000000000..ca45d8853f48
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-tests-optional.patch
@@ -0,0 +1,28 @@
+--- a/CMakeLists.txt 2015-01-21 01:30:56.784894492 +0100
++++ b/CMakeLists.txt 2015-01-21 01:34:51.192505604 +0100
+@@ -57,7 +57,7 @@
+ add_definitions(-DQT_NO_URL_CAST_FROM_STRING)
+
+ set(REQUIRED_QT_VERSION 5.2.0)
+-find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG REQUIRED Widgets DBus Network Concurrent Xml Test)
++find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG REQUIRED Widgets DBus Network Concurrent Xml)
+
+ find_package(GSSAPI)
+ set_package_properties(GSSAPI PROPERTIES DESCRIPTION "Allows KIO to make use of certain HTTP authentication services"
+@@ -85,10 +85,13 @@
+ endif()
+ include(CheckLibraryExists)
+ add_subdirectory(src)
+-add_subdirectory(autotests)
+
+-if (NOT KIOCORE_ONLY)
+-add_subdirectory(tests)
++if(BUILD_TESTING)
++ find_package(Qt5Test ${REQUIRED_QT_VERSION} CONFIG REQUIRED)
++ add_subdirectory(autotests)
++ if (NOT KIOCORE_ONLY)
++ add_subdirectory(tests)
++ endif()
+ endif()
+
+ # create a Config.cmake and a ConfigVersion.cmake file and install them
diff --git a/kde-frameworks/kio/kio-5.12.0.ebuild b/kde-frameworks/kio/kio-5.12.0.ebuild
new file mode 100644
index 000000000000..ab7e0212b2fe
--- /dev/null
+++ b/kde-frameworks/kio/kio-5.12.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework providing transparent file and data management"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="acl kerberos X"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtscript:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ dev-libs/libxml2
+ dev-libs/libxslt
+ acl? (
+ sys-apps/attr
+ virtual/acl
+ )
+ kerberos? ( virtual/krb5 )
+ X? ( dev-qt/qtx11extras:5 )
+ !<kde-base/kio-extras-5.0.95-r1:5
+"
+DEPEND="${RDEPEND}
+ $(add_frameworks_dep kdoctools)
+ dev-qt/qtconcurrent:5
+ test? ( sys-libs/zlib )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXrender
+ x11-proto/xproto
+ )
+"
+PDEPEND="
+ $(add_frameworks_dep kded)
+"
+
+# tests hang
+RESTRICT="test"
+
+src_prepare() {
+ # whole patch should be upstreamed, doesn't work in PATCHES
+ epatch "${FILESDIR}/${PN}-tests-optional.patch"
+
+ kde5_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package acl)
+ $(cmake-utils_use_find_package kerberos GSSAPI)
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}
diff --git a/kde-frameworks/kio/metadata.xml b/kde-frameworks/kio/metadata.xml
new file mode 100644
index 000000000000..a23f444b67d6
--- /dev/null
+++ b/kde-frameworks/kio/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>