summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-12 13:48:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-12 14:37:38 +0200
commit07314d80b1e14e94cd4ef0c3ed9af035fd351c6b (patch)
tree59536fbb79a5ea1749d76427e36777a1aa28a901 /kde-frameworks/kpeople/kpeople-5.74.0.ebuild
parentkde-frameworks/kpackage: 5.74.0 version bump (diff)
downloadgentoo-07314d80b1e14e94cd4ef0c3ed9af035fd351c6b.tar.gz
gentoo-07314d80b1e14e94cd4ef0c3ed9af035fd351c6b.tar.bz2
gentoo-07314d80b1e14e94cd4ef0c3ed9af035fd351c6b.zip
kde-frameworks/kpeople: 5.74.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kpeople/kpeople-5.74.0.ebuild')
-rw-r--r--kde-frameworks/kpeople/kpeople-5.74.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-frameworks/kpeople/kpeople-5.74.0.ebuild b/kde-frameworks/kpeople/kpeople-5.74.0.ebuild
new file mode 100644
index 000000000000..0ce077647206
--- /dev/null
+++ b/kde-frameworks/kpeople/kpeople-5.74.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.14.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="KDE contact person abstraction library"
+HOMEPAGE="https://invent.kde.org/frameworks/kpeople"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kitemviews-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ # personsmodeltest segfaults, bug 668192
+ local myctestargs=(
+ -j1
+ -E "(persondatatest)"
+ )
+
+ ecm_src_test
+}