summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-09 10:26:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-09 10:28:53 +0100
commitc64dcb9389b6c3fb6c5977e5c366e348517021bf (patch)
treea05269f66b3fba3617c7d76d0793548f6c1c0b49 /kde-frameworks/kpeople
parentkde-frameworks/kpackage: 5.78.0 version bump (diff)
downloadgentoo-c64dcb9389b6c3fb6c5977e5c366e348517021bf.tar.gz
gentoo-c64dcb9389b6c3fb6c5977e5c366e348517021bf.tar.bz2
gentoo-c64dcb9389b6c3fb6c5977e5c366e348517021bf.zip
kde-frameworks/kpeople: 5.78.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kpeople')
-rw-r--r--kde-frameworks/kpeople/Manifest1
-rw-r--r--kde-frameworks/kpeople/kpeople-5.78.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/kde-frameworks/kpeople/Manifest b/kde-frameworks/kpeople/Manifest
index 3450c455e6d5..505ff6e971a0 100644
--- a/kde-frameworks/kpeople/Manifest
+++ b/kde-frameworks/kpeople/Manifest
@@ -1,2 +1,3 @@
DIST kpeople-5.74.0.tar.xz 61664 BLAKE2B 96155d2501dad4431dfb372c5fa78cecfd95bf17251bae489d272ddcddceb5c4ae7aa564484fe9e3d3d73b83d265c98246ef9bfbce5f523e70cd85ec52489907 SHA512 c85ed5e3010d25153957159f6bda46882dbe806b9029aeeb5326ecde6b8e4f3a43bd37a57104757563f1ee7014fb216385c962a25bc0438cf4633bb4b41016cc
DIST kpeople-5.77.0.tar.xz 61636 BLAKE2B ad026024f93691c432275abf0b7f057800440f1c79aa1a54d62dbc0c05339c14c7844b32c099f3bbf4f5274c418c6c478aceb0c00f5ee0d3d958d814b66291fe SHA512 578efc5dec52fa32b5c87e5054ab3501c9af92ae2af9d6595c776f213ed54002ff45fb5499c07bc69269dde69717e76410d0779fbe104243888ac3ff9dea045e
+DIST kpeople-5.78.0.tar.xz 61648 BLAKE2B e4d134e8f4653c95150a668b2b45442b9aafc81fe73bfd02f64a52d5d02c997c1547e90dbdbf2d589bb7b0b9f8d738ddfbd1d4d5d03cb9edc9f4c733b93d0c44 SHA512 8790041bd80339e068a2c36b5b441e3928244334db71c4a1f9291d4297639158d8cd5b7f87ef85913844c92c9be1195738832c24015f2fa52d533bcf130d11ec
diff --git a/kde-frameworks/kpeople/kpeople-5.78.0.ebuild b/kde-frameworks/kpeople/kpeople-5.78.0.ebuild
new file mode 100644
index 000000000000..a1289e761496
--- /dev/null
+++ b/kde-frameworks/kpeople/kpeople-5.78.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.1
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="KDE contact person abstraction library"
+HOMEPAGE="https://invent.kde.org/frameworks/kpeople"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kitemviews-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ # personsmodeltest segfaults, bug 668192
+ local myctestargs=(
+ -j1
+ -E "(persondatatest)"
+ )
+
+ ecm_src_test
+}