summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-09 10:26:02 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-09 10:26:02 +0100
commit4a0634bce699428c4053b19b4026eef1873c90e3 (patch)
tree74d56785520d5464fc905540bb3666bdb324cd00 /kde-frameworks/kquickcharts/kquickcharts-5.78.0.ebuild
parentkde-frameworks/kplotting: 5.78.0 version bump (diff)
downloadgentoo-4a0634bce699428c4053b19b4026eef1873c90e3.tar.gz
gentoo-4a0634bce699428c4053b19b4026eef1873c90e3.tar.bz2
gentoo-4a0634bce699428c4053b19b4026eef1873c90e3.zip
kde-frameworks/kquickcharts: 5.78.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kquickcharts/kquickcharts-5.78.0.ebuild')
-rw-r--r--kde-frameworks/kquickcharts/kquickcharts-5.78.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-frameworks/kquickcharts/kquickcharts-5.78.0.ebuild b/kde-frameworks/kquickcharts/kquickcharts-5.78.0.ebuild
new file mode 100644
index 000000000000..83dc705fdff1
--- /dev/null
+++ b/kde-frameworks/kquickcharts/kquickcharts-5.78.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_EXAMPLES="true"
+ECM_QTHELP="false"
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.1
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="QtQuick plugin providing high-performance charts"
+HOMEPAGE="https://invent.kde.org/frameworks/kquickcharts"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ examples? (
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kdeclarative-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=$(usex examples)
+ )
+
+ ecm_src_configure
+}