summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-11-11 16:07:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-11 16:07:46 +0100
commit61c433dc07b3fa6b1921dcb41b927dbee0d9bc7b (patch)
tree2f4d9b6810f4cce1a9cfa8f0a12451f9e7594651 /kde-frameworks/krunner/krunner-5.40.0.ebuild
parentdev-python/pypy3: Inline deps and include dev-python/pycparser dep (diff)
downloadgentoo-61c433dc07b3fa6b1921dcb41b927dbee0d9bc7b.tar.gz
gentoo-61c433dc07b3fa6b1921dcb41b927dbee0d9bc7b.tar.bz2
gentoo-61c433dc07b3fa6b1921dcb41b927dbee0d9bc7b.zip
kde-frameworks: Add KDE Frameworks 5.40.0
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'kde-frameworks/krunner/krunner-5.40.0.ebuild')
-rw-r--r--kde-frameworks/krunner/krunner-5.40.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-frameworks/krunner/krunner-5.40.0.ebuild b/kde-frameworks/krunner/krunner-5.40.0.ebuild
new file mode 100644
index 000000000000..d84dbe1fcc1f
--- /dev/null
+++ b/kde-frameworks/krunner/krunner-5.40.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for providing different actions given a string query"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep plasma)
+ $(add_frameworks_dep solid)
+ $(add_frameworks_dep threadweaver)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ !<kde-apps/kapptemplate-15.12.3-r1:5
+"
+
+src_test() {
+ # requires virtual dbus #630672
+ local myctestargs=(
+ -E "(dbusrunnertest)"
+ )
+ kde5_src_test
+}