summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-10 21:19:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-12 23:13:14 +0200
commita7030fcd38880ac327f749bb528f65a0a4ee7ae7 (patch)
tree08ecff369172b6779cc7b6295ff2f1a069b73859 /kde-frameworks/kwayland/kwayland-5.63.0.ebuild
parentapp-office/kraft: Accept kde-frameworks/kcontacts (diff)
downloadgentoo-a7030fcd38880ac327f749bb528f65a0a4ee7ae7.tar.gz
gentoo-a7030fcd38880ac327f749bb528f65a0a4ee7ae7.tar.bz2
gentoo-a7030fcd38880ac327f749bb528f65a0a4ee7ae7.zip
kde-frameworks: Add KDE Frameworks 5.63.0
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kwayland/kwayland-5.63.0.ebuild')
-rw-r--r--kde-frameworks/kwayland/kwayland-5.63.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-frameworks/kwayland/kwayland-5.63.0.ebuild b/kde-frameworks/kwayland/kwayland-5.63.0.ebuild
new file mode 100644
index 000000000000..14617478e013
--- /dev/null
+++ b/kde-frameworks/kwayland/kwayland-5.63.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Qt-style client and server library wrapper for Wayland libraries"
+HOMEPAGE="https://cgit.kde.org/kwayland.git"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtgui 'egl')
+ >=dev-libs/wayland-1.15.0
+ media-libs/mesa[egl]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/wayland-protocols-1.15
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_qt_dep qtwayland)
+"
+
+# All failing, I guess we need a virtual wayland server
+RESTRICT+=" test"