summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-20 12:04:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-20 14:24:14 +0100
commitcacd874af64e05e5ea6c27086ed0d9fffb2abc17 (patch)
treed55a7ec84d81718e50897abcbbde08391d1e8601 /kde-frameworks/plasma
parentdev-python/ujson: Stabilize 5.0.0 arm64, #831545 (diff)
downloadgentoo-cacd874af64e05e5ea6c27086ed0d9fffb2abc17.tar.gz
gentoo-cacd874af64e05e5ea6c27086ed0d9fffb2abc17.tar.bz2
gentoo-cacd874af64e05e5ea6c27086ed0d9fffb2abc17.zip
kde-frameworks/plasma: Fix Kickoff context menu missing option(s)
Upstream commit e9ba0c54f2c01bb530370c16502cf304fc18b3f6 KDE-bug: https://bugs.kde.org/show_bug.cgi?id=448590 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/plasma')
-rw-r--r--kde-frameworks/plasma/files/plasma-5.90.0-KDEBUG-448590.patch32
-rw-r--r--kde-frameworks/plasma/plasma-5.90.0-r1.ebuild75
2 files changed, 107 insertions, 0 deletions
diff --git a/kde-frameworks/plasma/files/plasma-5.90.0-KDEBUG-448590.patch b/kde-frameworks/plasma/files/plasma-5.90.0-KDEBUG-448590.patch
new file mode 100644
index 000000000000..4bbb7a8ce1b0
--- /dev/null
+++ b/kde-frameworks/plasma/files/plasma-5.90.0-KDEBUG-448590.patch
@@ -0,0 +1,32 @@
+From e9ba0c54f2c01bb530370c16502cf304fc18b3f6 Mon Sep 17 00:00:00 2001
+From: Alexander Lohnau <alexander.lohnau@gmx.de>
+Date: Mon, 17 Jan 2022 19:58:53 +0100
+Subject: [PATCH] Corona::containmentForScreen: Ignore activities when an empty
+ string is used
+
+With the other overloads being deprecated, consumers are forced to put in an empty string
+for the activity. As one can see in the pre-existing code, an empty string indicates
+that the activity should be ignored. Consequently we should skip the activity check, when
+we got an empty string.
+
+BUG: 448590
+---
+ src/plasma/corona.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/plasma/corona.cpp b/src/plasma/corona.cpp
+index f034d7b2e..8f532d690 100644
+--- a/src/plasma/corona.cpp
++++ b/src/plasma/corona.cpp
+@@ -206,7 +206,7 @@ Containment *Corona::containmentForScreen(int screen, const QString &activity, c
+ for (Containment *cont : std::as_const(d->containments)) {
+ /* clang-format off */
+ if (cont->lastScreen() == screen
+- && (cont->activity().isEmpty() || cont->activity() == activity)
++ && ((cont->activity().isEmpty() || activity.isEmpty()) || cont->activity() == activity)
+ && (cont->containmentType() == Plasma::Types::DesktopContainment
+ || cont->containmentType() == Plasma::Types::CustomContainment)) { /* clang-format on */
+ containment = cont;
+--
+GitLab
+
diff --git a/kde-frameworks/plasma/plasma-5.90.0-r1.ebuild b/kde-frameworks/plasma/plasma-5.90.0-r1.ebuild
new file mode 100644
index 000000000000..801c23c0c8ee
--- /dev/null
+++ b/kde-frameworks/plasma/plasma-5.90.0-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="${PN}-framework"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Plasma framework"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="gles2-only man wayland X"
+
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[gles2-only=,X=]
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kactivities-${PVCUT}*:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kdeclarative-${PVCUT}*:5
+ =kde-frameworks/kglobalaccel-${PVCUT}*:5
+ =kde-frameworks/kguiaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
+ !gles2-only? ( media-libs/libglvnd[X?] )
+ wayland? (
+ =kde-frameworks/kwayland-${PVCUT}*:5
+ media-libs/libglvnd
+ )
+ X? (
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ x11-libs/libX11
+ x11-libs/libxcb
+ )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="man? ( >=kde-frameworks/kdoctools-${PVCUT}:5 )"
+
+PATCHES=( "${FILESDIR}/${P}-KDEBUG-448590.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package !gles2-only OpenGL)
+ $(cmake_use_find_package man KF5DocTools)
+ $(cmake_use_find_package wayland EGL)
+ $(cmake_use_find_package wayland KF5Wayland)
+ $(cmake_use_find_package X X11)
+ $(cmake_use_find_package X XCB)
+ )
+
+ ecm_src_configure
+}