summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 10:27:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 14:03:48 +0200
commit64aa333e5583d97e0c79fbaab9e0d081306746c7 (patch)
treeafc45113905a61843b091a2cea9bc284100a34be /kde-frameworks/prison/prison-5.50.0.ebuild
parentkde-apps/kpat: Add FRAMEWORKS_MINIMAL,QT_MINIMAL defs (diff)
downloadgentoo-64aa333e5583d97e0c79fbaab9e0d081306746c7.tar.gz
gentoo-64aa333e5583d97e0c79fbaab9e0d081306746c7.tar.bz2
gentoo-64aa333e5583d97e0c79fbaab9e0d081306746c7.zip
kde-frameworks: Add KDE Frameworks 5.50.0
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'kde-frameworks/prison/prison-5.50.0.ebuild')
-rw-r--r--kde-frameworks/prison/prison-5.50.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/kde-frameworks/prison/prison-5.50.0.ebuild b/kde-frameworks/prison/prison-5.50.0.ebuild
new file mode 100644
index 000000000000..a48a6c1a0c39
--- /dev/null
+++ b/kde-frameworks/prison/prison-5.50.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="QRCode and data matrix barcode library"
+HOMEPAGE="https://cgit.kde.org/prison.git"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="qml"
+
+DEPEND="
+ $(add_qt_dep qtgui)
+ media-gfx/qrencode:=
+ media-libs/libdmtx
+ qml? ( $(add_qt_dep qtdeclarative) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package qml Qt5Quick)
+ )
+
+ kde5_src_configure
+}