summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-09 11:50:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-09 13:31:40 +0200
commit78d3baee6a4c834139f8030a632e31db75cab0c6 (patch)
tree97353bfd1f6a7a440e3975e56e8b4ed8e8a01c26 /kde-frameworks/prison/prison-5.70.0.ebuild
parentapp-text/libmspub: Fix build with GCC 10, EAPI-7 bump (diff)
downloadgentoo-78d3baee6a4c834139f8030a632e31db75cab0c6.tar.gz
gentoo-78d3baee6a4c834139f8030a632e31db75cab0c6.tar.bz2
gentoo-78d3baee6a4c834139f8030a632e31db75cab0c6.zip
kde-frameworks: Add KDE Frameworks 5.70.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/prison/prison-5.70.0.ebuild')
-rw-r--r--kde-frameworks/prison/prison-5.70.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-frameworks/prison/prison-5.70.0.ebuild b/kde-frameworks/prison/prison-5.70.0.ebuild
new file mode 100644
index 000000000000..ea1ffc8cdec5
--- /dev/null
+++ b/kde-frameworks/prison/prison-5.70.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="QRCode and data matrix barcode library"
+HOMEPAGE="https://cgit.kde.org/prison.git"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="qml"
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ media-gfx/qrencode:=
+ media-libs/libdmtx
+ qml? ( >=dev-qt/qtdeclarative-${QTMIN}:5 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt5Quick)
+ )
+
+ ecm_src_configure
+}