summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-07-14 13:46:10 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-14 13:46:10 +0200
commit82d39affe7c0394f58b7dbda11a4df2d233e86d1 (patch)
tree0c87d649221962703f877bfcae356c45a4d72b6c /kde-frameworks/purpose
parentkde-apps/kde-dev-utils: Fix build with KF-5.48 (diff)
downloadgentoo-82d39affe7c0394f58b7dbda11a4df2d233e86d1.tar.gz
gentoo-82d39affe7c0394f58b7dbda11a4df2d233e86d1.tar.bz2
gentoo-82d39affe7c0394f58b7dbda11a4df2d233e86d1.zip
kde-frameworks: Add KDE Frameworks 5.48
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.48.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index d6168e5ebc71..2d4059dc9720 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1,2 +1,3 @@
DIST purpose-5.46.0.tar.xz 119424 BLAKE2B d786255ff0032e5c06414e5f42a06299d604bc76425832646b20f37887e80ed8a75eca0ff551993cb70c761241c317f14336c4e38d9bd9c4c0c971d4e461d044 SHA512 682dff7d8b160203b81bada628637c82822bf020acdd838cfc298b978b2b695ad413a40d955fd76c2bbed3c0debee4ebf17f31e34951ef50a1a75c912725c207
DIST purpose-5.47.0.tar.xz 127936 BLAKE2B b8b32e86f9d180b346abd21faed6c975d79ef55e01463f6d031970f0933449348aa3b9c959fa538c437ba9dec87a73c17f6c73e0d53cc659ad5f51bb3f2b1ad9 SHA512 7df3bfceec07b7d7c6e95d23943330723aa07468d4089aedb7067ffb33b25e336732d0afc5cd3c4ec901c243ba05c0031ad68dd3603510f301f05c20343a7268
+DIST purpose-5.48.0.tar.xz 133160 BLAKE2B 13cf79286cfef7c841bf088842a772de672021121466eabd21d34da69938a040eb4aa1c00e8d3f09c425f2259c346e97f87a0173679ba1f03f32f08a9b9346e8 SHA512 5c181d5e01a844d4dbadab82cccfc2c0ba018c3fa30d6618b037797ff8b8632235d436711ab78bccdec0ce4f39028f002969afc14738f07d422c9c872ff39aba
diff --git a/kde-frameworks/purpose/purpose-5.48.0.ebuild b/kde-frameworks/purpose/purpose-5.48.0.ebuild
new file mode 100644
index 000000000000..6ca976f20fe6
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.48.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_QTHELP="false"
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+kaccounts"
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ kaccounts? (
+ $(add_kdeapps_dep kaccounts-integration)
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}"
+
+# requires running environment
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package kaccounts KAccounts)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst(){
+ kde5_pkg_postinst
+
+ if ! has_version "kde-misc/kdeconnect[app]" ; then
+ elog "Optional runtime dependency:"
+ elog "kde-misc/kdeconnect[app] (send through KDE Connect)"
+ fi
+}