summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-11-14 02:40:02 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-11-14 03:46:21 +1100
commit3590519f6327cd955ddc8cd28999a35d935b417a (patch)
tree6f49892057aa5fdc43b436e23b7b48f55017e61e /kde-frameworks/sonnet/sonnet-5.16.0.ebuild
parentprofiles: mask kde-frameworks/{knotifications,ktextwidgets}[speech] (diff)
downloadgentoo-3590519f6327cd955ddc8cd28999a35d935b417a.tar.gz
gentoo-3590519f6327cd955ddc8cd28999a35d935b417a.tar.bz2
gentoo-3590519f6327cd955ddc8cd28999a35d935b417a.zip
kde-frameworks: version bump 5.16.0
Package-Manager: portage-2.2.24
Diffstat (limited to 'kde-frameworks/sonnet/sonnet-5.16.0.ebuild')
-rw-r--r--kde-frameworks/sonnet/sonnet-5.16.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/sonnet-5.16.0.ebuild b/kde-frameworks/sonnet/sonnet-5.16.0.ebuild
new file mode 100644
index 000000000000..b56eb9dc3920
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.16.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde5
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="+aspell hunspell nls"
+
+RDEPEND="
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell )
+"
+DEPEND="${RDEPEND}
+ nls? ( dev-qt/linguist-tools:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package aspell)
+ $(cmake-utils_use_find_package hunspell)
+ )
+
+ kde5_src_configure
+}