summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 10:27:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 14:03:48 +0200
commit64aa333e5583d97e0c79fbaab9e0d081306746c7 (patch)
treeafc45113905a61843b091a2cea9bc284100a34be /kde-frameworks/sonnet
parentkde-apps/kpat: Add FRAMEWORKS_MINIMAL,QT_MINIMAL defs (diff)
downloadgentoo-64aa333e5583d97e0c79fbaab9e0d081306746c7.tar.gz
gentoo-64aa333e5583d97e0c79fbaab9e0d081306746c7.tar.bz2
gentoo-64aa333e5583d97e0c79fbaab9e0d081306746c7.zip
kde-frameworks: Add KDE Frameworks 5.50.0
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'kde-frameworks/sonnet')
-rw-r--r--kde-frameworks/sonnet/Manifest1
-rw-r--r--kde-frameworks/sonnet/sonnet-5.50.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/Manifest b/kde-frameworks/sonnet/Manifest
index 1c14e97d6488..7b351399352f 100644
--- a/kde-frameworks/sonnet/Manifest
+++ b/kde-frameworks/sonnet/Manifest
@@ -1,2 +1,3 @@
DIST sonnet-5.46.0.tar.xz 286760 BLAKE2B 646dabdd56f405ea521aa7011057d03ec45e1d2902b15ef992ccc285dccf457d8f8dcd7c64a13f67b0dab486a06bfa817081dd5536fa8e6a880a34e7d22068ed SHA512 537a103ae6a15b9f94e317f396bcd3dd791715e596ac094dfaf88fb48e7eca682481fc8b040cc405c0db740d2c1c3edc9b73e96a0ad47925a4a8b6dbf9682880
DIST sonnet-5.49.0.tar.xz 286104 BLAKE2B 445e2ee87212a22dea6503800d71826d3a168bc6751ebee620df5d3591fffb6e176fbc5227d5d04b8b96c981060414c041dc1ed71b058cc050cae5ded3c1829f SHA512 1f94c81aa2afaf88a4bd5dc8bc30ff4a6773cb96db80d5cef891e25493e968a5fe9c752a82991ac9f718b3ffd3ae67b7bff99d2acb1bbd41e25bd0474acd8dea
+DIST sonnet-5.50.0.tar.xz 286156 BLAKE2B f8b71d132c329819fccb22a55953c84e6ba419e04a4a3d79b03503f189c54aade52297cc0d3196ca39b3005858dda96ac3f379098da051d1c50dc653c7b7a673 SHA512 ac0f5a0f729150d305410a4b91e3db7f1ede4148116821364611984eabfe4533fcd0a0ae4fd25f515a1b44b8983156224ef0da9fc4513be04b5b411a4dc62174
diff --git a/kde-frameworks/sonnet/sonnet-5.50.0.ebuild b/kde-frameworks/sonnet/sonnet-5.50.0.ebuild
new file mode 100644
index 000000000000..c71996ffd9f6
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.50.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="aspell +hunspell nls"
+
+RDEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package aspell ASPELL)
+ $(cmake-utils_use_find_package hunspell HUNSPELL)
+ )
+
+ kde5_src_configure
+}