summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-12 10:24:51 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-12 15:35:00 +0100
commit9f729a3ed257b5878ea19a9bae536e90546dde9d (patch)
tree4cf6fbf0ff3bfc39b541d81b55fb2cfee0a64827 /kde-frameworks/syntax-highlighting/syntax-highlighting-5.54.0.ebuild
parentdev-lang/mujs: stabilize v1.0.5 on amd64 (diff)
downloadgentoo-9f729a3ed257b5878ea19a9bae536e90546dde9d.tar.gz
gentoo-9f729a3ed257b5878ea19a9bae536e90546dde9d.tar.bz2
gentoo-9f729a3ed257b5878ea19a9bae536e90546dde9d.zip
kde-frameworks: Add KDE Frameworks 5.54.0
Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/syntax-highlighting/syntax-highlighting-5.54.0.ebuild')
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.54.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.54.0.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.54.0.ebuild
new file mode 100644
index 000000000000..a8ff643ba92e
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.54.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Framework for syntax highlighting"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtxmlpatterns)
+"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+
+src_install() {
+ kde5_src_install
+ dobin "${BUILD_DIR}"/bin/katehighlightingindexer
+}