summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-09 01:42:04 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-09 14:09:35 +0200
commit5a2fb0265adf6c431258322ff36db6172429aed1 (patch)
treebf50fa14f4de15d3434d405119c44db48dd3dd99 /kde-frameworks/syntax-highlighting
parentkde-frameworks/sonnet: 5.82.0 version bump (diff)
downloadgentoo-5a2fb0265adf6c431258322ff36db6172429aed1.tar.gz
gentoo-5a2fb0265adf6c431258322ff36db6172429aed1.tar.bz2
gentoo-5a2fb0265adf6c431258322ff36db6172429aed1.zip
kde-frameworks/syntax-highlighting: 5.82.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/syntax-highlighting')
-rw-r--r--kde-frameworks/syntax-highlighting/Manifest1
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.82.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/kde-frameworks/syntax-highlighting/Manifest b/kde-frameworks/syntax-highlighting/Manifest
index dcdf808a9364..8cb45fc9efda 100644
--- a/kde-frameworks/syntax-highlighting/Manifest
+++ b/kde-frameworks/syntax-highlighting/Manifest
@@ -1,3 +1,4 @@
DIST syntax-highlighting-5.80.0-fix-path-style-w-alt-value.patch.xz 6880 BLAKE2B 036a4a680fc52533b1bc3fe798b622b0a98a1142fd33e0f8f187d55e62a420cbc2d8e301fe873f6af33409d37fe155654cab09051b93054f281acf33acd581ce SHA512 19163f297f1f41cda1a95c4fc532055954a3bb59eda8d4a684a8fdd22b2a595e2cf48eafb5688fd7b8e8c5790ed6c3ab93a52340d2929ffa214ee7698103af11
DIST syntax-highlighting-5.80.0.tar.xz 2272788 BLAKE2B 45a116be75f998cb9a9cbf378418d030135eff1d1d3eb21932b202f22495fcbaa67f133dc1ae55bbcac24725cca847a2dbd880a5f5c1e39aa318a5b342365c22 SHA512 f24fb943f095b44092f62eca2a52f4b0f9ad0ce705bb0b0f8a17a9e3cda7a9892794218119e77cbc376d48ebb336904f862dbdd2715d932e7bc1c197dcbfba29
DIST syntax-highlighting-5.81.0.tar.xz 2281616 BLAKE2B 415ccb8602a9c46b26da2a0273581b8e742f79eb48d10fb604e87cbe24f3f7466c5da1bd00d6d7bd03a7a953c1d338d826908e17ed6d7fa3e54b86889174ecfc SHA512 ae8a0a75fffab6e050df298fab8c403c8b55885750177fa5e6c316091b927436b89f8385b7904420dbfbc8915d3dae89d290b01a5bd089d682dbcf10b4cbd7b5
+DIST syntax-highlighting-5.82.0.tar.xz 2290880 BLAKE2B 14a98534b4e0ec85bd3bb3603c6330f665b5d2a3958f1b9034e48fdc542aca0c0eca80a1bc5c75179c480ffb40189dd94a847093e81ab4af91442a9e323f7d32 SHA512 4487fece4b144fcdc3b03bc0c11573dcdb0bb073218f25a98a7d08fe55db0fde027f32b5614fa5083097136310cae46d7d28288f7f874eaa2fbd930af2d9fb16
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.82.0.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.82.0.ebuild
new file mode 100644
index 000000000000..02499f839b90
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.82.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="forceoptional"
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Framework for syntax highlighting"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ dev-lang/perl
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+ dobin "${BUILD_DIR}"/bin/katehighlightingindexer
+}