summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-14 00:36:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-14 08:51:25 +0200
commit9efd24de6c1fdb4a027b91db473262aba16731e0 (patch)
tree2b546c79713a9915fb32d1fd0542ba5c5354ed81 /kde-frameworks/syntax-highlighting
parentprofiles: mask ruby 2.4 for removal (diff)
downloadgentoo-9efd24de6c1fdb4a027b91db473262aba16731e0.tar.gz
gentoo-9efd24de6c1fdb4a027b91db473262aba16731e0.tar.bz2
gentoo-9efd24de6c1fdb4a027b91db473262aba16731e0.zip
kde-frameworks: Add KDE Frameworks 5.71.0
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/syntax-highlighting')
-rw-r--r--kde-frameworks/syntax-highlighting/Manifest1
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.71.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/kde-frameworks/syntax-highlighting/Manifest b/kde-frameworks/syntax-highlighting/Manifest
index b23a8e88e999..fc0377926d80 100644
--- a/kde-frameworks/syntax-highlighting/Manifest
+++ b/kde-frameworks/syntax-highlighting/Manifest
@@ -1 +1,2 @@
DIST syntax-highlighting-5.70.0.tar.xz 1606544 BLAKE2B 573a16979e9d2adff8562312c7681acbfbfaac906cf5eef2b1c8ae4131a555b89e4900d0d0e63b1a2fab3ac535e7c2daf0d847637d16d9eed9f4a07b30554c53 SHA512 59a05fd274cb11b893351cc10747600e03ced88cdc738eee26689e9a2a97b07db05805c0b0dcadbf02809254bd170b04f27b8372abb26b769bc6e962c615b9e0
+DIST syntax-highlighting-5.71.0.tar.xz 1611320 BLAKE2B 4790a9bbc956d1ad2b723cd34c67a9a9c7b5d3a8ad82b0f5f8fc385ff9f89dfce79e2e940f456b589b567c98debbc366d211da982bd8199c53604bc0a24d6592 SHA512 d2d79821172e59ced6de1053960d265c96cd08897cc638b6a64ea412364490b8857661a48b710bfb0906bbb2b9749cff867fbfc23767558fc26f9e9c535d8e17
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.71.0.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.71.0.ebuild
new file mode 100644
index 000000000000..9e72dae4c24b
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.71.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="forceoptional"
+QTMIN=5.14.1
+inherit ecm kde.org
+
+DESCRIPTION="Framework for syntax highlighting"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ dev-lang/perl
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+ dobin "${BUILD_DIR}"/bin/katehighlightingindexer
+}