summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-28 20:11:25 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-31 16:38:33 +0100
commitd5ef1ad9b7485a1b7e9d9042b1e50562d20dfbe5 (patch)
tree3dc39868b42ac9465ee8398bdf675ed8b74cb59d /kde-frameworks/syntax-highlighting
parentdev-lang/perl: Drop old (diff)
downloadgentoo-d5ef1ad9b7485a1b7e9d9042b1e50562d20dfbe5.tar.gz
gentoo-d5ef1ad9b7485a1b7e9d9042b1e50562d20dfbe5.tar.bz2
gentoo-d5ef1ad9b7485a1b7e9d9042b1e50562d20dfbe5.zip
kde-frameworks/syntax-highlighting: More bash syntax fixes
See also: https://invent.kde.org/frameworks/syntax-highlighting/-/issues/5 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/syntax-highlighting')
-rw-r--r--kde-frameworks/syntax-highlighting/Manifest1
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.77.0-r1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/syntax-highlighting/Manifest b/kde-frameworks/syntax-highlighting/Manifest
index 2fc8c08a2dad..edbe03f0b212 100644
--- a/kde-frameworks/syntax-highlighting/Manifest
+++ b/kde-frameworks/syntax-highlighting/Manifest
@@ -1,2 +1,3 @@
DIST syntax-highlighting-5.74.0.tar.xz 2028848 BLAKE2B b4641cd116b851564650a59a1354590b1fcca551a28fd0ea4034b5c95369a39084d0de83370416f10e2f4e51f724ab4bce5f22e97259013358aab54b980ca5b1 SHA512 6dfc9540ca4ec2c76c9b96a864a24bba6923529d72605dcd36136809250be12c366f52bf3dda02564169744729172eec2f0d3f69137d374d81af826ec97bc3b7
+DIST syntax-highlighting-5.77.0-bash-zsh-fixes.patch.xz 91824 BLAKE2B 4d201e62aecc7126f11d52ef2d68c308e61f7e167312270baf093eab379a7d95efaa38fec604701ad0fc15e8e050191a00a4075dac488c957fabe4dc4994065f SHA512 598eb3ed82f2bd072750730e6f9492d821a63cc2ebb4877e83aa482597a6cfb50ac721945f5c176c45d75de970dfba3c79f0e048db9076d7451743e672512c97
DIST syntax-highlighting-5.77.0.tar.xz 2145120 BLAKE2B de91836509fd6264fe0b79f1a7153c4d581913870ec207bd4d69ce24c5d00d92e49ebc70d147715a732626805cf68045be6490ff6ae7e199454c53a4c82ec2dd SHA512 057e9be24608cd856ee8aea355ddc63da9a11d50c388ae303e1f34cdf3a7ac99c592de51e0f04fa2254246ad796ced5029117b22ca71420b6089139d827a31b9
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.77.0-r1.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.77.0-r1.ebuild
new file mode 100644
index 000000000000..536d033a9cfb
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.77.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="forceoptional"
+QTMIN=5.15.1
+inherit ecm kde.org
+
+DESCRIPTION="Framework for syntax highlighting"
+SRC_URI+=" https://dev.gentoo.org/~asturm/distfiles/${P}-bash-zsh-fixes.patch.xz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ dev-lang/perl
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${WORKDIR}"/${P}-bash-zsh-fixes.patch )
+
+src_install() {
+ ecm_src_install
+ dobin "${BUILD_DIR}"/bin/katehighlightingindexer
+}