summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-11-14 15:26:22 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-14 18:44:03 +0100
commit1e26db27d854996701077b9f697184c092e1add1 (patch)
tree39553cd73c8b1d65be1a033a48bebf3d2f6d9c5c /kde-frameworks
parentsys-apps/baselayout: 2.7-r1 bump (diff)
downloadgentoo-1e26db27d854996701077b9f697184c092e1add1.tar.gz
gentoo-1e26db27d854996701077b9f697184c092e1add1.tar.bz2
gentoo-1e26db27d854996701077b9f697184c092e1add1.zip
kde-frameworks/frameworkintegration: 5.76.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.76.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 2684ca3638ba..a442828f8070 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.74.0.tar.xz 1754176 BLAKE2B f325c8362182c066f7fef108a350e9c9378e084c7955e1395fb44918759dbd7e5f55cae037525b286cf9f6b0c67788a766b62bdf737994378b1978a7ef7dd507 SHA512 4bf533b261c149a10ed4b4607f532b57b989f6e130c417a0398216ddbe1b4b3ab964009aa5c021bdc92960f8c25c7f5c66cf8606ed7956b25adfa401d0f08e68
DIST frameworkintegration-5.75.0.tar.xz 1754740 BLAKE2B 8a3d58fcfc35da8df3b4482cb4550cef7312071d92b168d87555119f124350847d870616b908f24a73f08d03c04bf944b0a9c9c33d29113656e0a2581ced814f SHA512 38c3182d7278ca985acb9f4a9a8c47fa1e7b61a6c23a8285000fd67d1ae4fdc59d2f05f48471ade38c92a35ffb8fafeb4092f46704f3501e2e0dbb7b94d602ea
+DIST frameworkintegration-5.76.0.tar.xz 1754768 BLAKE2B 8b2dbed7f8b57647b796475646abe16258cdfa4321c0648121c891f9bba662abcb573dcc74bb24b4dea21b5b6d899732a36c874984e0848682300d4537241392 SHA512 7f54c0c2c70eddb8442fe28e009994a80f5627294d235ec1a341e71f6ac9abbd5a6515018c883ce1825a36478403ed5f4bca03424f077abbba28f1f29f4820d4
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.76.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.76.0.ebuild
new file mode 100644
index 000000000000..694c122e0a59
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.76.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.1
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+# requires running Plasma environment
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}