summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-11 14:55:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-11 17:36:50 +0200
commit2812bdcd500edc0ea5265aac8e7c6ecff9e9f572 (patch)
tree0bf462d83e79178ec765332e155d2852e77d420b /kde-frameworks
parentkde-frameworks/sonnet: 5.72.0 version bump (diff)
downloadgentoo-2812bdcd500edc0ea5265aac8e7c6ecff9e9f572.tar.gz
gentoo-2812bdcd500edc0ea5265aac8e7c6ecff9e9f572.tar.bz2
gentoo-2812bdcd500edc0ea5265aac8e7c6ecff9e9f572.zip
kde-frameworks/syntax-highlighting: 5.72.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/syntax-highlighting/Manifest1
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.72.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/kde-frameworks/syntax-highlighting/Manifest b/kde-frameworks/syntax-highlighting/Manifest
index fc0377926d80..31a438ad53c1 100644
--- a/kde-frameworks/syntax-highlighting/Manifest
+++ b/kde-frameworks/syntax-highlighting/Manifest
@@ -1,2 +1,3 @@
DIST syntax-highlighting-5.70.0.tar.xz 1606544 BLAKE2B 573a16979e9d2adff8562312c7681acbfbfaac906cf5eef2b1c8ae4131a555b89e4900d0d0e63b1a2fab3ac535e7c2daf0d847637d16d9eed9f4a07b30554c53 SHA512 59a05fd274cb11b893351cc10747600e03ced88cdc738eee26689e9a2a97b07db05805c0b0dcadbf02809254bd170b04f27b8372abb26b769bc6e962c615b9e0
DIST syntax-highlighting-5.71.0.tar.xz 1611320 BLAKE2B 4790a9bbc956d1ad2b723cd34c67a9a9c7b5d3a8ad82b0f5f8fc385ff9f89dfce79e2e940f456b589b567c98debbc366d211da982bd8199c53604bc0a24d6592 SHA512 d2d79821172e59ced6de1053960d265c96cd08897cc638b6a64ea412364490b8857661a48b710bfb0906bbb2b9749cff867fbfc23767558fc26f9e9c535d8e17
+DIST syntax-highlighting-5.72.0.tar.xz 1621628 BLAKE2B 5638451e11244cf0a82602c3d062f60e87a70ed2444bda6248d3d1ecddc96a3d26ea21a957fcede8eb18847477637220f7682c67792d04707ede98dffc852839 SHA512 cbeb375a0c5af7646848f6d2df112f5ded5cb8614ab8054fae4133ff5420624879bb3db57928d5528731f100497ccb30b348555444eded5a87b95be49e747c23
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.72.0.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.72.0.ebuild
new file mode 100644
index 000000000000..352f17f8e6fa
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.72.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="forceoptional"
+QTMIN=5.14.2
+inherit ecm kde.org
+
+DESCRIPTION="Framework for syntax highlighting"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ dev-lang/perl
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+ dobin "${BUILD_DIR}"/bin/katehighlightingindexer
+}