summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-12-17 10:40:10 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-12-18 00:00:40 +0100
commit493d4577957e4af1834656c7c31f445a9960bdd5 (patch)
tree753aeef3ddc5176cf64ea4555e3bfcbcde25a89a /kde-frameworks
parentkde-frameworks/solid: 5.246.0 version bump (diff)
downloadgentoo-493d4577957e4af1834656c7c31f445a9960bdd5.tar.gz
gentoo-493d4577957e4af1834656c7c31f445a9960bdd5.tar.bz2
gentoo-493d4577957e4af1834656c7c31f445a9960bdd5.zip
kde-frameworks/sonnet: 5.246.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/sonnet/Manifest1
-rw-r--r--kde-frameworks/sonnet/sonnet-5.246.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/Manifest b/kde-frameworks/sonnet/Manifest
index ebd03c819421..ae918c7550df 100644
--- a/kde-frameworks/sonnet/Manifest
+++ b/kde-frameworks/sonnet/Manifest
@@ -1,2 +1,3 @@
DIST sonnet-5.112.0.tar.xz 2437888 BLAKE2B b6efedfaf19bbce80b2ca6eb922c6f1e655ff95a625be1a9c8d1398b486c7dbefedf6c645854033fd5dd66585ac5d2b981012a2220fbfb2b91ff4839b6929155 SHA512 51dd8ff203fdde5f783672fda88a425fa703eb3d064f7897248bd40163ba16b305341b6fdfeb9c9c0e6a3bec7a55b83baf649cabb1431aae0dd9f255f8ee780c
DIST sonnet-5.113.0.tar.xz 2437896 BLAKE2B 41fa3ecb2d2e3d83f25365ba4bbbb4d5f186750f3a4379ca73bca2f5b988bd7122eb32e9b0ea082deb9d422811659d107eb80343ec8c8b661b50a94141bb987c SHA512 db1e6ef5b768ce9796292fd776a98758c3a3c2481ae64ca97e28b3978764cddd2586c2ee92862f97d20e427ff76ea160837b87837894395a881ffc1a272100a2
+DIST sonnet-5.246.0.tar.xz 2441568 BLAKE2B 9f99c938d4419bbcc81e32df79ced793654822350e6c102f84318c4729646555dc6c192d336cf6d22a3cd54e30f8bf0990b5650c174a257b9babe20de1cda798 SHA512 b52d1b63ab65ad38da256901862f7cf5587cd77d6c446d1f14da69d5d828186414607e05e2801400d5c1d1abdbe0a6f3a8e60525257c7116ecf6621d1b093304
diff --git a/kde-frameworks/sonnet/sonnet-5.246.0.ebuild b/kde-frameworks/sonnet/sonnet-5.246.0.ebuild
new file mode 100644
index 000000000000..58b177c678d8
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.246.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_DESIGNERPLUGIN="true"
+QTMIN=6.6.0
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64"
+IUSE="aspell +hunspell qml"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui,widgets]
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+ qml? ( >=dev-qt/qtdeclarative-${QTMIN}:6 )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=">=dev-qt/qttools-${QTMIN}:6[linguist]"
+
+CMAKE_SKIP_TESTS=(
+ # bug 779994
+ sonnet-test_autodetect
+ # bug 680032
+ sonnet-test_settings
+ sonnet-test_highlighter
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package aspell ASPELL)
+ $(cmake_use_find_package hunspell HUNSPELL)
+ -DSONNET_USE_QML=$(usex qml)
+ )
+
+ ecm_src_configure
+}