summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-10 14:44:17 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-10 18:04:12 +0200
commit49a143688c9380c36ee79666eda206a15479dbb7 (patch)
tree2ff66555c1c0b16c5ed65f76137cb6613453efc2 /kde-frameworks
parentkde-frameworks/plasma: 5.75.0 version bump (diff)
downloadgentoo-49a143688c9380c36ee79666eda206a15479dbb7.tar.gz
gentoo-49a143688c9380c36ee79666eda206a15479dbb7.tar.bz2
gentoo-49a143688c9380c36ee79666eda206a15479dbb7.zip
kde-frameworks/purpose: 5.75.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.75.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index 086a0ce5670e..2e2a7a2194bc 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1 +1,2 @@
DIST purpose-5.74.0.tar.xz 156216 BLAKE2B 7d810f2d3b1af7cd041b8e9449fc5934bca7b739b5edf7fe1f5da553f264f189cfac0dd715dddf66a6f46be0a9389dae5d9eb35558b0c41b89dd36e53d945ccd SHA512 dea52fd5d10cc0c34ecab742b691675076ddf1346e2b352cd5f74cd266576f85eb9d721bf68a29cea62f9879b826bf375b70580451c31bdd33509f57ae3cf23a
+DIST purpose-5.75.0.tar.xz 156260 BLAKE2B 907722db174faeb48bb7513a5b0e7705a4685ec3dd8667cdfe40bff3a66929d235dd832b7c335a7d6ed66ebf18ee8763ff37ace2f24950bc43548a849e5a2cd6 SHA512 21e4b6649e953e910653eb045ed485823f857acb2fa48a864ff20a716ef34471fd1e8a5d3984f7c0b7d7516757943aa2ee965a1fc40390d5def3890ccda99a2e
diff --git a/kde-frameworks/purpose/purpose-5.75.0.ebuild b/kde-frameworks/purpose/purpose-5.75.0.ebuild
new file mode 100644
index 000000000000..bc4f598c495a
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.75.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.14.2
+inherit ecm kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="bluetooth +dolphin +kaccounts"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ dolphin? ( =kde-frameworks/knotifications-${PVCUT}*:5 )
+ kaccounts? (
+ >=kde-apps/kaccounts-integration-19.04.3:5
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:5 )
+ kaccounts? ( net-libs/accounts-qml )
+"
+
+# requires running environment
+RESTRICT+=" test"
+
+src_prepare() {
+ ecm_src_prepare
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package dolphin KF5Notifications)
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Optional dependencies:"
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}