summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-04-30 23:36:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-05-04 22:49:51 +0200
commit58b55e8517e023acb1f1aa44950759fc0ebd7a04 (patch)
tree4678db40c3dca5b2d91d7dd961bc068ce25ea550 /kde-frameworks
parentkde-frameworks/kio: drop 5.90.0* (diff)
downloadgentoo-58b55e8517e023acb1f1aa44950759fc0ebd7a04.tar.gz
gentoo-58b55e8517e023acb1f1aa44950759fc0ebd7a04.tar.bz2
gentoo-58b55e8517e023acb1f1aa44950759fc0ebd7a04.zip
kde-frameworks/knewstuff: drop 5.90.0*
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/knewstuff/Manifest1
-rw-r--r--kde-frameworks/knewstuff/files/knewstuff-5.90.0-add-conditional-cache-preference.patch61
-rw-r--r--kde-frameworks/knewstuff/files/knewstuff-5.90.0-ensure-correct-ProvidersUrl.patch27
-rw-r--r--kde-frameworks/knewstuff/knewstuff-5.90.0-r1.ebuild55
4 files changed, 0 insertions, 144 deletions
diff --git a/kde-frameworks/knewstuff/Manifest b/kde-frameworks/knewstuff/Manifest
index a50642f686a5..ea7976edf076 100644
--- a/kde-frameworks/knewstuff/Manifest
+++ b/kde-frameworks/knewstuff/Manifest
@@ -1,3 +1,2 @@
-DIST knewstuff-5.90.0.tar.xz 1151308 BLAKE2B 3ee001569596c96b7a28696b1be22f5138f7f274ed87b7255d3809a32304b3eacf594ab78627266d8227bb7330fd1e90526b2d93bf4f82c780050bd5d1f7c548 SHA512 d80b743691eb9665e0df196a69db3cee2247bbfe6c34ea5e9511c94558d2e807c9aca867aef6cd4344eaae6f252d9fff6b3e7a31c152b8a8b69b8d54813ede28
DIST knewstuff-5.92.0.tar.xz 1155052 BLAKE2B ee3485c1e3371c139019bb1889aedb112f40c0bb0ee1c92c159b3a6b8a84208d53de10fb1d368852927b7a65e6e1cee3afcf99aa821e8468c67f8b0ac49db79d SHA512 689089724f53ecd59bc79e046bb0b3f64e7a3bd7c8d9a5cd8be15d13bdc045e0484e05a2e0a87ab0134744da829becf8fc669a9e17b7668dafec3fff8e62a2a8
DIST knewstuff-5.93.0.tar.xz 1155216 BLAKE2B 9aad129dcfa08a6a7258ef4869a9e949e5a182c4e3f5e286a096c7935a08c7c5991b517c24743cc3a0685e27e2ccb069d44431cbc6033b9e6242db547e42e59b SHA512 ed18c8d1dda39db68d2c426936ba4d2576b0b7298dd306ad92101c992fda1420ffd9bfbd54b2bd9ee9afcfda6ca72b68258b46d6f151bc8b99a1c82577fca383
diff --git a/kde-frameworks/knewstuff/files/knewstuff-5.90.0-add-conditional-cache-preference.patch b/kde-frameworks/knewstuff/files/knewstuff-5.90.0-add-conditional-cache-preference.patch
deleted file mode 100644
index 80a8451ec990..000000000000
--- a/kde-frameworks/knewstuff/files/knewstuff-5.90.0-add-conditional-cache-preference.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From e1c6f2bf383876a31cd3e3f9e6edcaa19dc0a7dd Mon Sep 17 00:00:00 2001
-From: Dan Leinir Turthra Jensen <admin@leinir.dk>
-Date: Wed, 9 Feb 2022 16:17:58 +0000
-Subject: [PATCH] Add conditional cache preference to http requests
-
-If we have a cache that's older than 7 days, assume that it's out of
-date and actually try again. If it's younger than that, assume that it's
-just the same, and prefer our cached version, if we have one.
-
-The logic here is an attempt at striking a balance between using our cache
-to its fullest potential (as in, reducing server-side load and network
-roundtrips in general) while also handling the situation where the
-information that we are fed about the cache is not entirely correct (such
-as the case where we're told there's no expiration date, but the data in
-fact does change). 7 days seems a sensible sort of deadline for that,
-though we could change that later if we need to.
-
-This was born out of a discussion on another kns review[1]
-
-Assume that no cache expiration time will be longer than 7 days, but otherwise prefer the cache
-This is mildly hacky, but if we don't do this, we end up with infinite cache expirations in some
-cases, which of course isn't really acceptable... See ed62ee20 for a situation where that happened.
-
-[1] https://invent.kde.org/frameworks/knewstuff/-/merge_requests/166#note_394067
----
- src/core/jobs/httpworker.cpp | 12 +++++++++++-
- 1 file changed, 11 insertions(+), 1 deletion(-)
-
-diff --git a/src/core/jobs/httpworker.cpp b/src/core/jobs/httpworker.cpp
-index b52161f6..208e1ef0 100644
---- a/src/core/jobs/httpworker.cpp
-+++ b/src/core/jobs/httpworker.cpp
-@@ -41,7 +41,6 @@ public:
- return nam.get(request);
- }
-
--private:
- QNetworkDiskCache cache;
- };
-
-@@ -101,6 +100,17 @@ static void addUserAgent(QNetworkRequest &request)
- agentHeader += QStringLiteral("-%1/%2").arg(QCoreApplication::instance()->applicationName(), QCoreApplication::instance()->applicationVersion());
- }
- request.setHeader(QNetworkRequest::UserAgentHeader, agentHeader);
-+
-+ // Assume that no cache expiration time will be longer than a week, but otherwise prefer the cache
-+ // This is mildly hacky, but if we don't do this, we end up with infinite cache expirations in some
-+ // cases, which of course isn't really acceptable... See ed62ee20 for a situation where that happened.
-+ QNetworkCacheMetaData cacheMeta{s_httpWorkerNAM->cache.metaData(request.url())};
-+ if (cacheMeta.isValid()) {
-+ const QDateTime nextWeek{QDateTime::currentDateTime().addDays(7)};
-+ if (cacheMeta.expirationDate().isValid() && cacheMeta.expirationDate() < nextWeek) {
-+ request.setAttribute(QNetworkRequest::CacheLoadControlAttribute, QNetworkRequest::PreferCache);
-+ }
-+ }
- }
-
- void HTTPWorker::startRequest()
---
-GitLab
-
diff --git a/kde-frameworks/knewstuff/files/knewstuff-5.90.0-ensure-correct-ProvidersUrl.patch b/kde-frameworks/knewstuff/files/knewstuff-5.90.0-ensure-correct-ProvidersUrl.patch
deleted file mode 100644
index 130ca3dfbd5d..000000000000
--- a/kde-frameworks/knewstuff/files/knewstuff-5.90.0-ensure-correct-ProvidersUrl.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From c8165b7a0d622e318b3353ccf257a8f229dd12c9 Mon Sep 17 00:00:00 2001
-From: Aleix Pol <aleixpol@kde.org>
-Date: Tue, 8 Feb 2022 11:48:11 +0100
-Subject: [PATCH] Engine: Ensure we are not using the wrong ProvidersUrl
-
----
- src/core/engine.cpp | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/core/engine.cpp b/src/core/engine.cpp
-index 139dda1a..c96ba890 100644
---- a/src/core/engine.cpp
-+++ b/src/core/engine.cpp
-@@ -264,6 +264,10 @@ bool Engine::init(const QString &configfile)
- Q_EMIT uploadEnabledChanged();
-
- m_providerFileUrl = group.readEntry("ProvidersUrl");
-+ if (m_providerFileUrl == QLatin1String("https://download.kde.org/ocs/providers.xml")) {
-+ m_providerFileUrl = QStringLiteral("https://autoconfig.kde.org/ocs/providers.xml");
-+ qCWarning(KNEWSTUFFCORE) << "Please make sure" << configfile << "has ProvidersUrl=https://autoconfig.kde.org/ocs/providers.xml";
-+ }
- if (group.readEntry("UseLocalProvidersFile", "false").toLower() == QLatin1String{"true"}) {
- // The local providers file is called "appname.providers", to match "appname.knsrc"
- m_providerFileUrl = QUrl::fromLocalFile(QLatin1String("%1.providers").arg(configFullPath.left(configFullPath.length() - 6))).toString();
---
-GitLab
-
diff --git a/kde-frameworks/knewstuff/knewstuff-5.90.0-r1.ebuild b/kde-frameworks/knewstuff/knewstuff-5.90.0-r1.ebuild
deleted file mode 100644
index 34fdae40c707..000000000000
--- a/kde-frameworks/knewstuff/knewstuff-5.90.0-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ECM_TEST="false"
-PVCUT=$(ver_cut 1-2)
-QTMIN=5.15.2
-inherit ecm kde.org
-
-DESCRIPTION="Framework for downloading and sharing additional application data"
-
-LICENSE="LGPL-2+"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
-IUSE="opds"
-
-DEPEND="
- >=dev-qt/qtdeclarative-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtnetwork-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=dev-qt/qtxml-${QTMIN}:5
- =kde-frameworks/attica-${PVCUT}*:5
- =kde-frameworks/karchive-${PVCUT}*:5
- =kde-frameworks/kcompletion-${PVCUT}*:5
- =kde-frameworks/kconfig-${PVCUT}*:5
- =kde-frameworks/kcoreaddons-${PVCUT}*:5
- =kde-frameworks/ki18n-${PVCUT}*:5
- =kde-frameworks/kiconthemes-${PVCUT}*:5
- =kde-frameworks/kio-${PVCUT}*:5
- =kde-frameworks/kitemviews-${PVCUT}*:5
- =kde-frameworks/kpackage-${PVCUT}*:5
- =kde-frameworks/kservice-${PVCUT}*:5
- =kde-frameworks/ktextwidgets-${PVCUT}*:5
- =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
- =kde-frameworks/kxmlgui-${PVCUT}*:5
- opds? ( =kde-frameworks/syndication-${PVCUT}*:5 )
-"
-RDEPEND="${DEPEND}
- >=kde-frameworks/kirigami-${PVCUT}:5
-"
-
-# https://mail.kde.org/pipermail/distributions/2022-February/001140.html
-PATCHES=(
- "${FILESDIR}/${P}-ensure-correct-ProvidersUrl.patch"
- "${FILESDIR}/${P}-add-conditional-cache-preference.patch"
-)
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package opds KF5Syndication)
- )
-
- ecm_src_configure
-}