summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-04-22 18:12:58 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-04-22 18:20:50 +0200
commit59302e58f1f7c849f5635e86c676443f4a01266f (patch)
tree330309764c4686ab5f5d8981337d5d4119b983de /kde-frameworks
parentkde-frameworks/kio: drop 5.102.0-r1 (diff)
downloadgentoo-59302e58f1f7c849f5635e86c676443f4a01266f.tar.gz
gentoo-59302e58f1f7c849f5635e86c676443f4a01266f.tar.bz2
gentoo-59302e58f1f7c849f5635e86c676443f4a01266f.zip
kde-frameworks/knewstuff: drop 5.102.0-r1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/knewstuff/Manifest1
-rw-r--r--kde-frameworks/knewstuff/files/knewstuff-5.102.0-fix-crash-in-QQuickQuestionListener.patch55
-rw-r--r--kde-frameworks/knewstuff/knewstuff-5.102.0-r1.ebuild52
3 files changed, 0 insertions, 108 deletions
diff --git a/kde-frameworks/knewstuff/Manifest b/kde-frameworks/knewstuff/Manifest
index 494a435f796e..032a648c093c 100644
--- a/kde-frameworks/knewstuff/Manifest
+++ b/kde-frameworks/knewstuff/Manifest
@@ -1,3 +1,2 @@
-DIST knewstuff-5.102.0.tar.xz 3406384 BLAKE2B 3c2ba49a86b2954865db706466b07c94cc2f0b5fd10084f35285ae44ebff9e4a8dc5d968292a13699cefde229386b7dda27eea70a13fdf1c45736361e8a9dce7 SHA512 2ec0b6a8be814267a3b97fa50eb2789d5e78741e67ecd82a9ea095075338814a7d4d31623a6b9f809c129eba6b85f55e5fc6d05d43307859eb1e3420620962b0
DIST knewstuff-5.104.0.tar.xz 3411440 BLAKE2B 5c5696708fb6b2ec68cc555ad1c78d57b1f9ad39ecf1304aadf27470f5f0a94294f2fcc2c9099ab5e1de23d2c0c6ffd8bf223b96711e53cdfc0f41d370f0dafc SHA512 6d757ba602a155eb7640fc62cbdae3bfebe2b4147fec0f60dd6fcaeeecdf45d20ad1ee5cfc0c4163f878e92fd42c7a3146543f899451728b810446b26a663b16
DIST knewstuff-5.105.0.tar.xz 3385168 BLAKE2B 251b3aea1fd20ce9c848c300c7508b7c162084e7ce2e84f50971b4c47a300e293f2037cdfc534bb3f179049dc2eb83cca8707867c29321cf73ff59f71778c514 SHA512 12aa8cccb6cb30b1f05e823a6ab900aa9618ac69bdfae4125db6890187394ac9920e57f767eaa7eaf822f7e5f1e988d9090ceaeda2fc92fc36cd96a530f1f721
diff --git a/kde-frameworks/knewstuff/files/knewstuff-5.102.0-fix-crash-in-QQuickQuestionListener.patch b/kde-frameworks/knewstuff/files/knewstuff-5.102.0-fix-crash-in-QQuickQuestionListener.patch
deleted file mode 100644
index 00bafeb28b93..000000000000
--- a/kde-frameworks/knewstuff/files/knewstuff-5.102.0-fix-crash-in-QQuickQuestionListener.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From c8e5b36e190f8b71ac14e3afd403debdbe3cf9a8 Mon Sep 17 00:00:00 2001
-From: David Edmundson <kde@davidedmundson.co.uk>
-Date: Sun, 29 Jan 2023 13:33:09 +0000
-Subject: [PATCH] Fix crash in QQuickQuestionListener
-
-The code path is:
- - we create a Question object
- - we show a prompt
- - we start a nested event loop to get this into a syncronous API
- - we return the result to the question object
-
-The lifespan of the question object is not controlled by the listener,
-during the nested event loop anything could have happened including
-deletion.
-
-BUG: 464624
-
-
-(cherry picked from commit e9e0e3faa986757ba096dbe599468f395b3461d3)
----
- src/qtquick/quickquestionlistener.cpp | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/src/qtquick/quickquestionlistener.cpp b/src/qtquick/quickquestionlistener.cpp
-index 81123b33..f760ef39 100644
---- a/src/qtquick/quickquestionlistener.cpp
-+++ b/src/qtquick/quickquestionlistener.cpp
-@@ -10,6 +10,7 @@
- #include "core/question.h"
-
- #include <QCoreApplication>
-+#include <QPointer>
-
- using namespace KNewStuffQuick;
-
-@@ -35,7 +36,7 @@ public:
- Private()
- {
- }
-- KNSCore::Question *question = nullptr;
-+ QPointer<KNSCore::Question> question;
- };
-
- QuickQuestionListener *QuickQuestionListener::instance()
-@@ -117,6 +118,6 @@ void KNewStuffQuick::QuickQuestionListener::passResponse(bool responseIsContinue
- break;
- }
- }
-- d->question = nullptr;
-+ d->question.clear();
- }
- }
---
-GitLab
-
diff --git a/kde-frameworks/knewstuff/knewstuff-5.102.0-r1.ebuild b/kde-frameworks/knewstuff/knewstuff-5.102.0-r1.ebuild
deleted file mode 100644
index f0932576d8b4..000000000000
--- a/kde-frameworks/knewstuff/knewstuff-5.102.0-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ECM_DESIGNERPLUGIN="true"
-ECM_TEST="false"
-PVCUT=$(ver_cut 1-2)
-QTMIN=5.15.5
-inherit ecm frameworks.kde.org
-
-DESCRIPTION="Framework for downloading and sharing additional application data"
-
-LICENSE="LGPL-2+"
-KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
-IUSE="opds"
-
-DEPEND="
- >=dev-qt/qtdeclarative-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtnetwork-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=dev-qt/qtxml-${QTMIN}:5
- =kde-frameworks/attica-${PVCUT}*:5
- =kde-frameworks/karchive-${PVCUT}*:5
- =kde-frameworks/kcompletion-${PVCUT}*:5
- =kde-frameworks/kconfig-${PVCUT}*:5
- =kde-frameworks/kcoreaddons-${PVCUT}*:5
- =kde-frameworks/ki18n-${PVCUT}*:5
- =kde-frameworks/kiconthemes-${PVCUT}*:5
- =kde-frameworks/kio-${PVCUT}*:5
- =kde-frameworks/kitemviews-${PVCUT}*:5
- =kde-frameworks/kpackage-${PVCUT}*:5
- =kde-frameworks/kservice-${PVCUT}*:5
- =kde-frameworks/ktextwidgets-${PVCUT}*:5
- =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
- =kde-frameworks/kxmlgui-${PVCUT}*:5
- opds? ( =kde-frameworks/syndication-${PVCUT}*:5 )
-"
-RDEPEND="${DEPEND}
- >=kde-frameworks/kirigami-${PVCUT}:5
-"
-
-PATCHES=( "${FILESDIR}/${P}-fix-crash-in-QQuickQuestionListener.patch" ) # KDE-bug 464624
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package opds KF5Syndication)
- )
-
- ecm_src_configure
-}