summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-03-11 09:57:11 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-03-11 10:05:36 +0100
commitca961d58787562debe5f7211c074916b13864430 (patch)
tree0f39081429e0ecea31c40c575a5c90d3b54eba13 /kde-frameworks
parentapp-admin/keepassxc: sync live 9999 version (diff)
downloadgentoo-ca961d58787562debe5f7211c074916b13864430.tar.gz
gentoo-ca961d58787562debe5f7211c074916b13864430.tar.bz2
gentoo-ca961d58787562debe5f7211c074916b13864430.zip
kde-frameworks/knewstuff: Fix link list dialog for installation button
See also: https://mail.kde.org/pipermail/distributions/2024-March/001482.html KDE-bug: https://bugs.kde.org/show_bug.cgi?id=482349 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/knewstuff/files/knewstuff-6.0.0-fix-kdebug-482349.patch42
-rw-r--r--kde-frameworks/knewstuff/knewstuff-6.0.0-r1.ebuild42
2 files changed, 84 insertions, 0 deletions
diff --git a/kde-frameworks/knewstuff/files/knewstuff-6.0.0-fix-kdebug-482349.patch b/kde-frameworks/knewstuff/files/knewstuff-6.0.0-fix-kdebug-482349.patch
new file mode 100644
index 000000000000..6e0b2ca3c025
--- /dev/null
+++ b/kde-frameworks/knewstuff/files/knewstuff-6.0.0-fix-kdebug-482349.patch
@@ -0,0 +1,42 @@
+From 49f2037ac22fcb430fadd5d7b29bd8af234573a4 Mon Sep 17 00:00:00 2001
+From: Akseli Lahtinen <akselmo@akselmo.dev>
+Date: Thu, 7 Mar 2024 16:01:44 +0000
+Subject: [PATCH] Fix link list dialog for installation button
+
+In gridview, installation buttons showed "Install..." for every item,
+even if the item had only single download link. This fixes it
+by showing correct button.
+
+The problem was using `entry` directly instead of `model`.
+
+BUG: 482349
+FIXED-IN: 6.1
+---
+ .../qml/private/entrygriddelegates/TileDelegate.qml | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/qtquick/qml/private/entrygriddelegates/TileDelegate.qml b/src/qtquick/qml/private/entrygriddelegates/TileDelegate.qml
+index 2fdee68b4..36224abe2 100644
+--- a/src/qtquick/qml/private/entrygriddelegates/TileDelegate.qml
++++ b/src/qtquick/qml/private/entrygriddelegates/TileDelegate.qml
+@@ -40,13 +40,13 @@ Private.GridTileDelegate {
+ visible: enabled
+ },
+ Kirigami.Action {
+- text: entry.downloadLinks.length === 1 ? i18ndc("knewstuff6", "Request installation of this item, available when there is exactly one downloadable item", "Install") : i18ndc("knewstuff6", "Show installation options, where there is more than one downloadable item", "Install…");
++ text: model.downloadLinks.length === 1 ? i18ndc("knewstuff6", "Request installation of this item, available when there is exactly one downloadable item", "Install") : i18ndc("knewstuff6", "Show installation options, where there is more than one downloadable item", "Install…");
+ icon.name: "install"
+ onTriggered: {
+- if (entry.downloadLinks.length === 1) {
+- newStuffEngine.install(entry.entry, NewStuff.ItemsModel.FirstLinkId);
++ if (model.downloadLinks.length === 1) {
++ newStuffEngine.install(entry, NewStuff.ItemsModel.FirstLinkId);
+ } else {
+- downloadItemsSheet.downloadLinks = entry.downloadLinks;
++ downloadItemsSheet.downloadLinks = model.downloadLinks;
+ downloadItemsSheet.entry = entry;
+ downloadItemsSheet.open();
+ }
+--
+GitLab
+
diff --git a/kde-frameworks/knewstuff/knewstuff-6.0.0-r1.ebuild b/kde-frameworks/knewstuff/knewstuff-6.0.0-r1.ebuild
new file mode 100644
index 000000000000..7b9468264281
--- /dev/null
+++ b/kde-frameworks/knewstuff/knewstuff-6.0.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_DESIGNERPLUGIN="true"
+ECM_TEST="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.2
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for downloading and sharing additional application data"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64"
+IUSE="opds"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui,network,widgets,xml]
+ >=dev-qt/qtdeclarative-${QTMIN}:6[widgets]
+ =kde-frameworks/attica-${PVCUT}*:6
+ =kde-frameworks/karchive-${PVCUT}*:6
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/kcoreaddons-${PVCUT}*:6
+ =kde-frameworks/ki18n-${PVCUT}*:6
+ =kde-frameworks/kpackage-${PVCUT}*:6
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:6
+ opds? ( =kde-frameworks/syndication-${PVCUT}*:6 )
+"
+RDEPEND="${DEPEND}
+ >=kde-frameworks/kirigami-${PVCUT}:6
+"
+
+PATCHES=( "${FILESDIR}/${P}-fix-kdebug-482349.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package opds KF6Syndication)
+ )
+
+ ecm_src_configure
+}