summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-05-15 13:28:36 +0200
committerJohannes Huber <johu@gentoo.org>2016-05-15 13:31:11 +0200
commit49df5318111ec04076679f0de9c42222091c1c40 (patch)
treefbbf719a7abbd9fa3ef854845f66aea2473b67c1 /kde-misc/ktoshiba/ktoshiba-5.3.ebuild
parentsci-mathematics/rstudio: Bump to 0.99.902 (diff)
downloadgentoo-49df5318111ec04076679f0de9c42222091c1c40.tar.gz
gentoo-49df5318111ec04076679f0de9c42222091c1c40.tar.bz2
gentoo-49df5318111ec04076679f0de9c42222091c1c40.zip
kde-misc/ktoshiba: Version bump 5.3
Package-Manager: portage-2.2.28
Diffstat (limited to 'kde-misc/ktoshiba/ktoshiba-5.3.ebuild')
-rw-r--r--kde-misc/ktoshiba/ktoshiba-5.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/kde-misc/ktoshiba/ktoshiba-5.3.ebuild b/kde-misc/ktoshiba/ktoshiba-5.3.ebuild
new file mode 100644
index 000000000000..b9226a147640
--- /dev/null
+++ b/kde-misc/ktoshiba/ktoshiba-5.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Function key (FN) monitoring for Toshiba laptops"
+HOMEPAGE="http://ktoshiba.sourceforge.net/"
+SRC_URI="http://prdownloads.sourceforge.net/${PN}/${P}.tar.xz"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ $(add_frameworks_dep kauth)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ net-libs/libmnl
+"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIBMNL_INCLUDE_DIRS=/usr/include/libmnl
+ )
+ kde5_src_configure
+}