summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-misc/socket-sentry
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-misc/socket-sentry')
-rw-r--r--kde-misc/socket-sentry/Manifest1
-rw-r--r--kde-misc/socket-sentry/files/socket-sentry-0.9.3-automagictests.patch20
-rw-r--r--kde-misc/socket-sentry/metadata.xml5
-rw-r--r--kde-misc/socket-sentry/socket-sentry-0.9.3-r1.ebuild58
4 files changed, 84 insertions, 0 deletions
diff --git a/kde-misc/socket-sentry/Manifest b/kde-misc/socket-sentry/Manifest
new file mode 100644
index 000000000000..d9f8c1e24af5
--- /dev/null
+++ b/kde-misc/socket-sentry/Manifest
@@ -0,0 +1 @@
+DIST socketsentry-0.9.3.tar.gz 156935 SHA256 1b8bfe859a2dd640647662e0b534a1f6dac429ee1252eed6887619704d9b26f6 SHA512 235e82370e8927ef03acb08af69dd97dfd67d9fa9a7c7d50bec1c504cd2d6d7bd3c102cb90cf212b772f838c1c1bce94b525bf2eecafe5827532d0f32c848c38 WHIRLPOOL 815a0867cec9984e07b110ed4c291e6d9db38bb2b9eb2fafa31330362cc4aba35610a118527265b0683292accd5733496e94b13f0a3e13d4fdb5e8e6522651f2
diff --git a/kde-misc/socket-sentry/files/socket-sentry-0.9.3-automagictests.patch b/kde-misc/socket-sentry/files/socket-sentry-0.9.3-automagictests.patch
new file mode 100644
index 000000000000..050e7b2efd25
--- /dev/null
+++ b/kde-misc/socket-sentry/files/socket-sentry-0.9.3-automagictests.patch
@@ -0,0 +1,20 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -42,7 +42,7 @@
+ # The link libraries should contain the code under test. The TEST_SUPPORT_LIBS are also linked
+ # automatically.
+ function (add_qtestlib_tests test_source_files)
+- if (DEFINED TEST_SUPPORT_LIBS)
++ if (DEFINED TEST_SUPPORT_LIBS AND WITH_TESTS)
+ foreach(test_file_src ${test_source_files})
+ get_filename_component(test_file_path ${test_file_src} PATH)
+ get_filename_component(test_file_base ${test_file_src} NAME_WE)
+@@ -54,7 +54,7 @@
+ target_link_libraries( ${test_exe} ${TEST_SUPPORT_LIBS} ${ARGN} )
+ add_test(${test_file_base} ${EXECUTABLE_OUTPUT_PATH}/${test_exe} )
+ endforeach(test_file_src)
+- endif (DEFINED TEST_SUPPORT_LIBS)
++ endif (DEFINED TEST_SUPPORT_LIBS AND WITH_TESTS)
+ endfunction(add_qtestlib_tests)
+
+ add_subdirectory (socketsentry-service)
diff --git a/kde-misc/socket-sentry/metadata.xml b/kde-misc/socket-sentry/metadata.xml
new file mode 100644
index 000000000000..8d1e86a9cefb
--- /dev/null
+++ b/kde-misc/socket-sentry/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>
diff --git a/kde-misc/socket-sentry/socket-sentry-0.9.3-r1.ebuild b/kde-misc/socket-sentry/socket-sentry-0.9.3-r1.ebuild
new file mode 100644
index 000000000000..f7f374c50ac2
--- /dev/null
+++ b/kde-misc/socket-sentry/socket-sentry-0.9.3-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde4-base user
+
+MY_PN="socketsentry"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A KDE plasmoid that displays real-time network traffic on your Linux computer"
+HOMEPAGE="http://code.google.com/p/socket-sentry"
+SRC_URI="http://socket-sentry.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug test"
+
+RDEPEND="
+ >=net-libs/libpcap-0.8
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gmock dev-cpp/gtest )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.9.3-automagictests.patch" )
+
+S="${WORKDIR}/${MY_P}"
+
+# tests fails to build, new gtest related?
+RESTRICT="test"
+
+pkg_setup() {
+ kde4-base_pkg_setup
+
+ SOCKETSENTRY_GROUP=${MY_PN}
+ enewgroup ${SOCKETSENTRY_GROUP}
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with test TESTS)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ ewarn
+ ewarn "Remember, in order to use ${PN} plasmoid, you have to"
+ ewarn "be in the '${SOCKETSENTRY_GROUP}' group."
+ ewarn
+ ewarn "Just run 'gpasswd -a <USER> ${SOCKETSENTRY_GROUP}', then have <USER> re-login."
+ ewarn
+}