summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-22 15:10:57 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-23 15:29:08 +0200
commit999c7ff3946ebc22d42311239b18ec1dd256e240 (patch)
tree5d34a058c38e2f30c78891235e63fdd203b0f54c /kde-misc/wacomtablet/wacomtablet-3.2.0.ebuild
parentsys-boot/grub: backport fix for bios boot partition on sparc64 (diff)
downloadgentoo-999c7ff3946ebc22d42311239b18ec1dd256e240.tar.gz
gentoo-999c7ff3946ebc22d42311239b18ec1dd256e240.tar.bz2
gentoo-999c7ff3946ebc22d42311239b18ec1dd256e240.zip
kde-misc/wacomtablet: 3.2.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'kde-misc/wacomtablet/wacomtablet-3.2.0.ebuild')
-rw-r--r--kde-misc/wacomtablet/wacomtablet-3.2.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/kde-misc/wacomtablet/wacomtablet-3.2.0.ebuild b/kde-misc/wacomtablet/wacomtablet-3.2.0.ebuild
new file mode 100644
index 000000000000..5071ef8da86f
--- /dev/null
+++ b/kde-misc/wacomtablet/wacomtablet-3.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="System settings module for Wacom tablets"
+HOMEPAGE="https://userbase.kde.org/Wacomtablet https://store.kde.org/p/1127862"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="sys-devel/gettext"
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ >=dev-libs/libwacom-0.30
+ >=x11-drivers/xf86-input-wacom-0.20.0
+ x11-libs/libXi
+ x11-libs/libxcb
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/libX11
+"
+
+src_test() {
+ # test needs DBus, bug 675548
+ local myctestargs=(
+ -E "(Test.KDED.DBusTabletService)"
+ )
+
+ kde5_src_test
+}