summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-22 18:46:03 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-23 15:59:11 +0100
commit4bc14b426eba4f391cb1f1ba56f5b189983b7acf (patch)
tree2c59343609deb00c7b4f904c8c4ad775824ebd9d /kde-plasma/breeze-gtk
parentkde-frameworks/plasma: Drop 5.88.0 (r0) (diff)
downloadgentoo-4bc14b426eba4f391cb1f1ba56f5b189983b7acf.tar.gz
gentoo-4bc14b426eba4f391cb1f1ba56f5b189983b7acf.tar.bz2
gentoo-4bc14b426eba4f391cb1f1ba56f5b189983b7acf.zip
kde-plasma/breeze-gtk: Fix unneeded outline
KDE-bug: https://bugs.kde.org/show_bug.cgi?id=443626 Upstream commit 6834ee83d09b7c56fbe3d137b660db25484573f3 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/breeze-gtk')
-rw-r--r--kde-plasma/breeze-gtk/breeze-gtk-5.23.3-r1.ebuild41
-rw-r--r--kde-plasma/breeze-gtk/files/breeze-gtk-5.23.3-fix-unneeded-outline.patch52
2 files changed, 93 insertions, 0 deletions
diff --git a/kde-plasma/breeze-gtk/breeze-gtk-5.23.3-r1.ebuild b/kde-plasma/breeze-gtk/breeze-gtk-5.23.3-r1.ebuild
new file mode 100644
index 000000000000..93b076e2fed7
--- /dev/null
+++ b/kde-plasma/breeze-gtk/breeze-gtk-5.23.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-3)
+PYTHON_COMPAT=( python3_{8..10} )
+inherit ecm kde.org python-any-r1
+
+DESCRIPTION="Official GTK+ port of Plasma's Breeze widget style"
+HOMEPAGE="https://invent.kde.org/plasma/breeze-gtk"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+BDEPEND="${PYTHON_DEPS}
+ dev-lang/sassc
+ $(python_gen_any_dep 'dev-python/pycairo[${PYTHON_USEDEP}]')
+ >=dev-util/cmake-3.16
+ >=kde-plasma/breeze-${PVCUT}:5
+"
+
+PATCHES=( "${FILESDIR}/${P}-fix-unneeded-outline.patch" ) # KDE-bug 443626
+
+python_check_deps() {
+ has_version "dev-python/pycairo[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ ecm_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPython3_EXECUTABLE="${PYTHON}"
+ )
+ ecm_src_configure
+}
diff --git a/kde-plasma/breeze-gtk/files/breeze-gtk-5.23.3-fix-unneeded-outline.patch b/kde-plasma/breeze-gtk/files/breeze-gtk-5.23.3-fix-unneeded-outline.patch
new file mode 100644
index 000000000000..b835094140a5
--- /dev/null
+++ b/kde-plasma/breeze-gtk/files/breeze-gtk-5.23.3-fix-unneeded-outline.patch
@@ -0,0 +1,52 @@
+From 6834ee83d09b7c56fbe3d137b660db25484573f3 Mon Sep 17 00:00:00 2001
+From: Yaroslav Sidlovsky <zawertun@gmail.com>
+Date: Thu, 18 Nov 2021 14:15:36 +0300
+Subject: [PATCH] Fixed toolbar buttons style, removing unneeded outline
+
+BUG: 443626
+
+
+(cherry picked from commit 23ba2a8dc728cd7105e5994ed1d4dc143f7d69a1)
+---
+ src/gtk3/widgets/_button.scss | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/src/gtk3/widgets/_button.scss b/src/gtk3/widgets/_button.scss
+index 4bd0ce7..e7250ee 100644
+--- a/src/gtk3/widgets/_button.scss
++++ b/src/gtk3/widgets/_button.scss
+@@ -176,6 +176,7 @@ $_dot_color: gtk("@theme_button_decoration_focus");
+
+ @include button(normal);
+ &.flat {
++ @include button(undecorated);
+ // to avoid adiacent buttons borders clashing when transitioning, the transition on the normal state is set
+ // to none, while it's added back in the hover state, so the button decoration will fade in on hover, but
+ // it won't fade out when the pointer leave the button allocation area. To make the transition more evident
+@@ -228,12 +229,15 @@ $_dot_color: gtk("@theme_button_decoration_focus");
+ }
+ &.flat:backdrop {
+ -gtk-icon-effect: none;
++ @include button(undecorated);
+ color: gtk("@theme_button_foreground_backdrop");
+ }
+ &.flat:disabled {
++ @include button(undecorated);
+ color: gtk("@theme_button_foreground_insensitive");
+ }
+ &.flat:backdrop:disabled {
++ @include button(undecorated);
+ color: gtk("@theme_button_foreground_backdrop_insensitive");
+ }
+ &:disabled {
+@@ -357,6 +361,7 @@ button {
+ &.flat:backdrop,
+ &.flat:disabled,
+ &.flat:backdrop:disabled {
++ @include button(undecorated);
+ color: gtkalpha($button_color, 0.8);
+ }
+ &:disabled {
+--
+GitLab
+