summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-11-03 10:37:19 +0100
committerJohannes Huber <johu@gentoo.org>2016-11-03 10:37:52 +0100
commit1ce9e4689917b76fb8aad74f5a3d1cd103d3bfa3 (patch)
tree89cee6924b02e699002f2a0cfe7b6a492d014358 /kde-plasma/kde-gtk-config/kde-gtk-config-2.2.1.ebuild
parentdev-vcs/mercurial: Stable for HPPA PPC64 (bug #582238). (diff)
downloadgentoo-1ce9e4689917b76fb8aad74f5a3d1cd103d3bfa3.tar.gz
gentoo-1ce9e4689917b76fb8aad74f5a3d1cd103d3bfa3.tar.bz2
gentoo-1ce9e4689917b76fb8aad74f5a3d1cd103d3bfa3.zip
kde-misc/kde-gtk-config -> kde-plasma/kde-gtk-config
Diffstat (limited to 'kde-plasma/kde-gtk-config/kde-gtk-config-2.2.1.ebuild')
-rw-r--r--kde-plasma/kde-gtk-config/kde-gtk-config-2.2.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/kde-plasma/kde-gtk-config/kde-gtk-config-2.2.1.ebuild b/kde-plasma/kde-gtk-config/kde-gtk-config-2.2.1.ebuild
new file mode 100644
index 000000000000..a28e70ef1bcd
--- /dev/null
+++ b/kde-plasma/kde-gtk-config/kde-gtk-config-2.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="bs ca ca@valencia cs da de el es et eu fi fr ga gl hu id it ja kk
+km lt mr nb nds nl pl pt pt_BR ro ru sk sl sv uk zh_CN zh_TW"
+inherit kde4-base
+
+DESCRIPTION="KDE Plasma systemsettings kcm to set GTK application look&feel"
+HOMEPAGE="https://projects.kde.org/kde-gtk-config"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+
+LICENSE="GPL-3"
+KEYWORDS="amd64 ~arm x86 ~x86-fbsd"
+SLOT="4"
+IUSE="debug"
+
+CDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/gtk+:3
+"
+DEPEND="
+ ${CDEPEND}
+ dev-util/automoc
+"
+RDEPEND="
+ ${CDEPEND}
+ !kde-misc/kcm_gtk
+ $(add_kdeapps_dep kcmshell)
+"
+
+PATCHES=( "${FILESDIR}/${P}-kdelibs-4.14.11.patch" )
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+ einfo
+ elog "If you notice missing icons in your GTK applications, you may have to install"
+ elog "the corresponding themes for GTK. A good guess would be x11-themes/oxygen-gtk"
+ elog "for example."
+ einfo
+}