summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-02-14 19:35:21 +0100
committerJohannes Huber <johu@gentoo.org>2017-02-14 21:39:31 +0100
commit153b248a877c7bf03d5d6ad9c41091aadca46f12 (patch)
treeecd5b72d41dec6058cdbf2c053a89446fc43f097 /kde-plasma/kinfocenter
parentdev-libs/openssl: mark 1.0.2k arm64/m68k/s390/sh stable (diff)
downloadgentoo-153b248a877c7bf03d5d6ad9c41091aadca46f12.tar.gz
gentoo-153b248a877c7bf03d5d6ad9c41091aadca46f12.tar.bz2
gentoo-153b248a877c7bf03d5d6ad9c41091aadca46f12.zip
kde-plasma: Version bump KDE Plasma 5.9.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.9.2.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index cea7b91b3a8b..a86395519abb 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -2,3 +2,4 @@ DIST glogo-small.png 24583 SHA256 0afc3eca084c327f8059166b86769f03c9c23e1e765bb4
DIST kde-workspace-4.11.22.tar.xz 13553668 SHA256 f035334e843d67ee88551ae9e6c5f64bf7b1edfe311b12501575fe74be0b03b7 SHA512 9def2cc8d1e597259966cd6cc44e9aad7ebe2c7cde5943e362c6782d1344e7da4fff0dddd0fe0c948bca159dba128d8a36006e1ae409415cd22f74955d0a9b95 WHIRLPOOL 14b0fcef19bda4b92a42612387fb6307a50dbb3620e911e3e0aaf5d764fb263e1959baae2e55cb71d92d064542844ae963b170bb960a9b7dc18a11627b731802
DIST kinfocenter-5.8.5.tar.xz 1269580 SHA256 f7bd2b1389245f73d89dfe0f6229e3ecd9e04bf7a235e369ca992d3ad3b27aba SHA512 35c66179f9947cc5b323584ca74040622c39ed273c9609bba4c712b07965a0e97c65d0c1b4b0d29a458d1741d59f657ff5d3cbc8ec92fcb4ce6ac402bf113e92 WHIRLPOOL b0ab085af294f93b00e35fe52ae6b955b70c9b7cbd1446f5faa00ccf1a59202fed94a9c0879a5b7e278b9867ab201ff1f11a64c070793cdfdfbd75c01066d387
DIST kinfocenter-5.9.1.tar.xz 1266224 SHA256 a10598a09a7f81acf4f613a6b16be2e1cbd1946885ea9444ac1011180488649c SHA512 2fedb59d96fb6a13aea469ece90f46136228e73354ae1298f14c63e54a7c93867a20f017753a9e0e2432cfdedcbf924caa90cc0f5eaad59339437febc36134ed WHIRLPOOL ca5020a4fdef8903e8cf06fe5b2f41f98f884ebbd3a3dd3e008b75d7fc77d69e5cba05a397517a0c8aa678da2daa087778fdb9250902a31c188083d325b0cd4e
+DIST kinfocenter-5.9.2.tar.xz 1266164 SHA256 bef138f07707893832bceba86525f43ce0605d0bf8633651024138b5b46a4be5 SHA512 6e9cc5f72cf55bf6cbdc5c31e3073b3c1e3c080144c4879e7fe42354c9d25d3e444873cbd319d24f3cab839e547ef4d6b6a6bb47361febe21b89c66a34a28553 WHIRLPOOL db2a0f84f1c56ffa48ec3ecbc614b60928f61a314b095875a9ce7f4b67f6f5e90afd85e51db53df7e781dd179bb57ee98a2c4df60288fb9d2d0bfb55811b8976
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.9.2.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.9.2.ebuild
new file mode 100644
index 000000000000..32bcb3c6afb4
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.9.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="true"
+inherit kde5
+
+DESCRIPTION="A utility that provides information about a computer system"
+HOMEPAGE="https://www.kde.org/applications/system/kinfocenter/"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="egl gles2 ieee1394 +opengl +pci wayland"
+
+REQUIRED_USE="egl? ( || ( gles2 opengl ) )"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ x11-libs/libX11
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? (
+ $(add_qt_dep qtgui 'gles2=')
+ media-libs/mesa[egl?,gles2?]
+ !gles2? ( media-libs/glu )
+ )
+ pci? ( sys-apps/pciutils )
+ wayland? ( $(add_frameworks_dep kwayland) )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep plasma)
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-base/kcontrol:4
+ !kde-plasma/kinfocenter:4
+ !kde-misc/about-distro
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package egl EGL)
+ $(cmake-utils_use_find_package gles2 OpenGLES)
+ $(cmake-utils_use_find_package ieee1394 RAW1394)
+ $(cmake-utils_use_find_package opengl OpenGL)
+ $(cmake-utils_use_find_package pci PCIUTILS)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
+
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if ! has_version "net-fs/nfs-utils"; then
+ einfo "Installing net-fs/nfs-utils will enable the NFS information module."
+ fi
+ if ! has_version "net-fs/samba" || ! has_version "net-fs/samba[server]"; then
+ einfo "Installing net-fs/samba[server(+)] will enable the Samba status information module."
+ fi
+}