summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-08-02 14:23:17 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-08-02 20:38:18 +0200
commit469d371ad11923cd3f0b5cd17d8064bc5a092984 (patch)
treed3fcb419e6f1dafcdd8fcdab3b59a9b11c9abcda /kde-plasma/kinfocenter
parentkde-plasma/khotkeys: 5.25.4 version bump (diff)
downloadgentoo-469d371ad11923cd3f0b5cd17d8064bc5a092984.tar.gz
gentoo-469d371ad11923cd3f0b5cd17d8064bc5a092984.tar.bz2
gentoo-469d371ad11923cd3f0b5cd17d8064bc5a092984.zip
kde-plasma/kinfocenter: 5.25.4 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.25.4.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index 7fe0f2f8b6d5..f86ff554b5c2 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -2,3 +2,4 @@ DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26
DIST kinfocenter-5.24.5.tar.xz 719404 BLAKE2B 49ac1db6f1e98fdd2575f43891ebb27448f211d61d811496f4a54170806ed2df80211f7248bec093e45855625b3ba6f768ec66b070b196de9452205b632fbbcf SHA512 598d7993808ac6f32ae89c2a50624caf81c4d7a355ae155469d79fda923d3bcd4256077863186a42d594ddd36c06ffb5c3fd02987cf638b2bc88dffdb9b47883
DIST kinfocenter-5.24.6.tar.xz 720088 BLAKE2B f124db8c27ddd95084ed569716807987510f23731ce8ece0d7f303be95f17764bde6e522dc72f8dc209fa5f81305f70e8cccc08e93e7b1fe4b983b6e2f38fdc1 SHA512 bb30faf3fdef1df6df7740210da4a63a596b6a354774dd46fabf7561df265eccac85c8fc500b3e5bcf48b8bbef60b4617aa5b3bc245ea10117e8e9a082f98717
DIST kinfocenter-5.25.3.tar.xz 733464 BLAKE2B 1d5cf23375588872f046b9d51e00a9e29b379e9eb50b2e3d2dc8674aa70c00e688bd3bc5e924249dbb48ef506b7c75fa6b2d46a2dc1a58baf26e97840bcd9dbe SHA512 17d0b00d8bd49a3a358bc239c849381e1ae2ca17b18723d4e546003bbd04731a4e325b66c2d952c2e65b5ae51eca882f97d8cc6484fba38cb3fa1df33772dbe0
+DIST kinfocenter-5.25.4.tar.xz 725412 BLAKE2B 1141c5dfb601db29d78bad1a6864a26526a4625277e305b57e70b57fe9cc7932c7d0cf8854540506e007704c18ff98772f4e0071430ebac2c018a982ad73368a SHA512 24ded8be42a7ad9f19889c6df0a2b0799d3db931368d2bd2c0d68fefa850539076c69dbbc7a26517d090f09aa6dd8ba4b7c6d4cce5b01a07b5c9d9bafb6ae33f
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.25.4.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.25.4.ebuild
new file mode 100644
index 000000000000..a284d1115d5e
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.25.4.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=5.95.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.5
+inherit ecm plasma.kde.org optfeature
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://userbase.kde.org/KInfoCenter"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="gles2-only usb"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[gles2-only=]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kpackage-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ gles2-only? ( media-libs/mesa[gles2] )
+ usb? ( virtual/libusb:1 )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+ >=kde-plasma/systemsettings-${PVCUT}:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package usb USB1)
+ )
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "NFS information module" net-fs/nfs-utils
+ optfeature "Samba status information module" net-fs/samba
+ optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature "advanced CPU information module" sys-apps/util-linux
+ fi
+ optfeature "Wayland information module" app-misc/wayland-utils
+ optfeature "OpenGL information module" x11-apps/mesa-progs
+ optfeature "PCI devices information module" sys-apps/pciutils
+ optfeature "X Server information module" x11-apps/xdpyinfo
+ ecm_pkg_postinst
+}