summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-23 18:51:56 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-23 18:54:05 +0200
commit56148d2ee3e83c17a64f8672d32143bcb2f56e02 (patch)
tree5a36a0e471249e90170111f32bfdb74897ff64b0 /kde-plasma/kinfocenter
parentwww-client/firefox: update patch URL (diff)
downloadgentoo-56148d2ee3e83c17a64f8672d32143bcb2f56e02.tar.gz
gentoo-56148d2ee3e83c17a64f8672d32143bcb2f56e02.tar.bz2
gentoo-56148d2ee3e83c17a64f8672d32143bcb2f56e02.zip
kde-plasma: Add KDE Plasma 5.14.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.14.2.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index 62a6318c3e6f..908c3af6b304 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -2,3 +2,4 @@ DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26
DIST kinfocenter-5.12.7.tar.xz 1286660 BLAKE2B fd1548666a9f47e6bcb168942ff9071c16dfc1095434bdee4a3626bc04bd64d89b75cb7bcff4e085fb52125b84faf4acd1cd2c7812dfcb18970a462245a1333e SHA512 440e1d9c6be280fee95681148f6f9c069529431f3367fd5938663afa840cd191c85fd995b9a0a4fb6ae143d2c74415cafcfc99e4a7d7e25dc99fdd3820608f9b
DIST kinfocenter-5.13.5.tar.xz 1286000 BLAKE2B d8e9278f3c7214e13403970e86ac72f5cad3ed2506752c297860d91f26e986b6bce806a7498b78e4517b8d6c8a0ff31e2d2b6f0117babb93839dc8c923cf6bbd SHA512 a54b3ef5df1855f3002965f70c2e627ddc0b1e69eaa36461da1018b9ffd6e033ca61c4890a358ddc22f6f9e66cab5cdbaa1ff5386dda29fe87248f8af5567e50
DIST kinfocenter-5.14.1.tar.xz 1323228 BLAKE2B 09432622249083656cb305220b7d9c4256df92e7fdf2bfd6457342add4b4abaaadf225454706de0646b06da8892f7c727b460d02b1254625688b5fe70cceabbe SHA512 994285a66e2a30a2d9850bf3099156ff27669f9d64f8f966bc231f4d0741760650ddc0ed96bfe865c0a46f1a61cdb1e45f467783f94834f0ff441814a6e37431
+DIST kinfocenter-5.14.2.tar.xz 1316660 BLAKE2B 8a6905531cc856e4e1f5aa084eb88c4edd76bf5a20749be0b6a5a8df96638a933207f8c19f7febd229a62d7fe1b48387fc9702df8fa4f8426a17ae28a1eef3c9 SHA512 562c4227cee6e0136a095f8807c5e143299353fb9a241f8bbf4e5048e2a30f780c6a75056cef5bf4b8e6418cd96e4e229181f7a13dd5d80ec92a98b15e90b806
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.14.2.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.14.2.ebuild
new file mode 100644
index 000000000000..215d99985102
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.14.2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="true"
+inherit kde5
+
+DESCRIPTION="A utility that provides information about a computer system"
+HOMEPAGE="https://www.kde.org/applications/system/kinfocenter/"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="gles2 ieee1394 +opengl +pci wayland"
+
+REQUIRED_USE="wayland? ( || ( gles2 opengl ) )"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ x11-libs/libX11
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? (
+ $(add_qt_dep qtgui 'gles2=')
+ media-libs/mesa[gles2?]
+ !gles2? ( media-libs/glu )
+ )
+ pci? ( sys-apps/pciutils )
+ wayland? (
+ $(add_frameworks_dep kwayland)
+ media-libs/mesa[egl]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep plasma)
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-apps/kcontrol:4
+ !kde-misc/about-distro
+ !kde-plasma/kinfocenter:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package ieee1394 RAW1394)
+ $(cmake-utils_use_find_package pci PCIUTILS)
+ $(cmake-utils_use_find_package wayland EGL)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
+
+ if has_version "dev-qt/qtgui[gles2]"; then
+ mycmakeargs+=( $(cmake-utils_use_find_package gles2 OpenGLES) )
+ else
+ mycmakeargs+=( $(cmake-utils_use_find_package opengl OpenGL) )
+ fi
+
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if ! has_version "net-fs/nfs-utils"; then
+ elog "Installing net-fs/nfs-utils will enable the NFS information module."
+ fi
+ if ! has_version "net-fs/samba"; then
+ elog "Installing net-fs/samba will enable the Samba status information module."
+ fi
+}