summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-27 06:00:20 +0100
committerSam James <sam@gentoo.org>2021-10-27 06:00:20 +0100
commit76b6a42cc3bdb1441a69ab23129120cc1dc3dffe (patch)
tree276914f87fbdb7e48d6eaefeb50083e535ae4603 /kde-plasma/kinfocenter
parentkde-plasma/khotkeys: 5.23.2 version bump (diff)
downloadgentoo-76b6a42cc3bdb1441a69ab23129120cc1dc3dffe.tar.gz
gentoo-76b6a42cc3bdb1441a69ab23129120cc1dc3dffe.tar.bz2
gentoo-76b6a42cc3bdb1441a69ab23129120cc1dc3dffe.zip
kde-plasma/kinfocenter: 5.23.2 version bump
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.23.2.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index 613ec969849b..1b9100fd8a0d 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,3 +1,4 @@
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-5.22.5.tar.xz 1170716 BLAKE2B 8e9cefdb426e9635928aa2b81359acc1e8b2113865b18109fa442efa7cd35684fdf911a39c3ce8a43c31afabced6820d6bac6ce31a5c00eb629f6a8462906a7b SHA512 7eaafde6f9a388e9d4cfe9a8f4057c462bf83f9fecdd39fdd96e05f4c5094c1a116bf66a781bba67721e63e8cfd5a8bfb32fb1906392c2acb70263afaa17c560
DIST kinfocenter-5.23.1.tar.xz 1152544 BLAKE2B 2d9704b86fac6e41637b22637c70cb0482230361e11547b8a8c8676afd2d794d7e85280b9cd2d5d0786c677941e10b9c34421426e94fc710805f5e11579f6863 SHA512 1dae1cef1ba7fe2ddc94555f528d51b5aec7aa30e6e65aa323d4b49615db527f083cb8dec3714be4e9824556d817a12f35c3f636370dc157d8e930edd1a87953
+DIST kinfocenter-5.23.2.tar.xz 1152748 BLAKE2B 8d05e2cd29822f1052f4dce6c3bc84408947862bd14a37e14911938a391a74b72bd25c4c5fda2baf9c9778545cfc82a08cc3834ada3f93f3be333ae1591f963f SHA512 6768e2686b43714c6a431ed2c67b2b176ace7d3886499b0e9d370680953cf1e06283768fca47a7ccdf83da119b6703fea8ac3077af6f1632158055bd522300c5
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.23.2.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.23.2.ebuild
new file mode 100644
index 000000000000..8c0e917a1080
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.23.2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=5.86.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+inherit ecm kde.org optfeature
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://userbase.kde.org/KInfoCenter"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="gles2-only ieee1394 +opengl +pci usb wayland +X"
+
+REQUIRED_USE="opengl? ( X ) wayland? ( || ( opengl gles2-only ) )"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[gles2-only=]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kpackage-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ gles2-only? ( media-libs/mesa[gles2] )
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? (
+ media-libs/libglvnd[X?]
+ !gles2-only? ( media-libs/glu )
+ )
+ pci? ( sys-apps/pciutils )
+ usb? ( virtual/libusb:1 )
+ wayland? (
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ media-libs/mesa[egl(+)]
+ )
+ X? ( x11-libs/libX11 )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+ >=kde-plasma/systemsettings-${PVCUT}:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package ieee1394 RAW1394)
+ $(cmake_use_find_package pci PCIUTILS)
+ $(cmake_use_find_package usb USB1)
+ $(cmake_use_find_package wayland EGL)
+ $(cmake_use_find_package wayland KF5Wayland)
+ $(cmake_use_find_package X X11)
+ )
+
+ if has_version "dev-qt/qtgui[gles2-only]"; then
+ mycmakeargs+=( $(cmake_use_find_package gles2-only OpenGLES) )
+ else
+ mycmakeargs+=( $(cmake_use_find_package opengl OpenGL) )
+ fi
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "NFS information module" net-fs/nfs-utils
+ optfeature "Samba status information module" net-fs/samba
+ optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature "advanced CPU information module" sys-apps/util-linux
+ fi
+ ecm_pkg_postinst
+}