summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-06-27 22:44:56 +0200
committerJohannes Huber <johu@gentoo.org>2018-06-27 22:45:24 +0200
commitad9b3995a238dd866e0e405907887ad30add40fa (patch)
tree26c0d64a118d352973220848dcd035958116e206 /kde-plasma/kinfocenter
parentdev-python/cliff-tablib: Support python3.6 (diff)
downloadgentoo-ad9b3995a238dd866e0e405907887ad30add40fa.tar.gz
gentoo-ad9b3995a238dd866e0e405907887ad30add40fa.tar.bz2
gentoo-ad9b3995a238dd866e0e405907887ad30add40fa.zip
kde-plasma: Version bump KDE Plasma 5.12.6
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.12.6.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index eef7e83df6bc..ca4e49dcb662 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,2 +1,3 @@
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-5.12.5.tar.xz 1270224 BLAKE2B 5c2b0148f82862d32393804bd98ca99ec71f476d4103f015f159420223bb695b8d237673aa94c12d9be4147b36c52d9cbbd0d8f0e69208f6afcb18363283a50f SHA512 f8178452b2611473733ec707be1683234bcd22bac381d6d8fa47e695653c5d2983dab37dd24dea19024cd4a68e4736bb08a3b197c8a6932a45c927ee7a61638d
+DIST kinfocenter-5.12.6.tar.xz 1276012 BLAKE2B 633f47373b7439ae48720c97debedd1e134c07d3a7b9028b0d7aa13e952c8945e2499c9c9d4582d25b275cdff57ceb8727ad0f58e7ffac063efcab66664f0490 SHA512 521d588d73bb32fa2020b8c4faacbdaa86e65fca421829566fb9a21a15750f6d9c912c2d948f8a11ffcd304d51d5f062c79147fc8703c345fd4a1153dc937ff6
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.12.6.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.12.6.ebuild
new file mode 100644
index 000000000000..e0627f416eeb
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.12.6.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="true"
+inherit kde5
+
+DESCRIPTION="A utility that provides information about a computer system"
+HOMEPAGE="https://www.kde.org/applications/system/kinfocenter/"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="gles2 ieee1394 +opengl +pci wayland"
+
+REQUIRED_USE="wayland? ( || ( gles2 opengl ) )"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ x11-libs/libX11
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? (
+ $(add_qt_dep qtgui 'gles2=')
+ media-libs/mesa[gles2?]
+ !gles2? ( media-libs/glu )
+ )
+ pci? ( sys-apps/pciutils )
+ wayland? (
+ $(add_frameworks_dep kwayland)
+ media-libs/mesa[egl]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep plasma)
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-apps/kcontrol:4
+ !kde-misc/about-distro
+ !kde-plasma/kinfocenter:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package ieee1394 RAW1394)
+ $(cmake-utils_use_find_package pci PCIUTILS)
+ $(cmake-utils_use_find_package wayland EGL)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
+
+ if has_version "dev-qt/qtgui[gles2]"; then
+ mycmakeargs+=( $(cmake-utils_use_find_package gles2 OpenGLES) )
+ else
+ mycmakeargs+=( $(cmake-utils_use_find_package opengl OpenGL) )
+ fi
+
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if ! has_version "net-fs/nfs-utils"; then
+ einfo "Installing net-fs/nfs-utils will enable the NFS information module."
+ fi
+ if ! has_version "net-fs/samba" || ! has_version "net-fs/samba[server]"; then
+ einfo "Installing net-fs/samba[server(+)] will enable the Samba status information module."
+ fi
+}