summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-30 14:35:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-30 16:32:29 +0200
commit3a88c6f1b382ab5ebfe61539039a694c0e123991 (patch)
tree08f3cf35bc863ba6278e2950b9c5e72e83efe7be /kde-plasma/ksshaskpass
parentacct-group/kvm: make virtualization the primary maintainer (diff)
downloadgentoo-3a88c6f1b382ab5ebfe61539039a694c0e123991.tar.gz
gentoo-3a88c6f1b382ab5ebfe61539039a694c0e123991.tar.bz2
gentoo-3a88c6f1b382ab5ebfe61539039a694c0e123991.zip
kde-plasma: Add KDE Plasma 5.16.4
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.16.4.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index f437c9237ad9..0f58d850ada2 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.15.5.tar.xz 21304 BLAKE2B 8664f783d08d789aab81e40cc6d0a7248f0fe25bab20803579ce0c3869a412d2fc8fecf709b4bfe7d900dc7b9af59042d4e648d5b5730a8fb7108f4ac39ba362 SHA512 296581dafc7068a0e536fb3f10dbd56bd288bec5b93f96e5f7d7b03be6cf9f279dbdeccc8c53da21316fa18d758e92513d8f5441d9e80dfee452c26ef1dddcbc
DIST ksshaskpass-5.16.3.tar.xz 21304 BLAKE2B 8c39a5bd6f67aa1b7218340d51a1a90c14dd5de7503605f0f22d051359815601a5ec0d700020510a8e857ecd5ce95e6d06a03a4d8c1a3b36031576715ef0ef0d SHA512 cd08827870ac002dfb45362fcd2dbe0ee61e8a621cc7dc0c67d5e6f810e96db6055cd2a2dde3fe21f93c1342e8f014e25b9d5873f38da8eeea79fb08eae27bde
+DIST ksshaskpass-5.16.4.tar.xz 21352 BLAKE2B 3de1328110a9eb699f68ec99bfc1906f856e1518da212305beeca9feb8a85fe8ee757ca8006a7d66a0cc5d49788a1ebdfbd020c054ee97a26276858a68eaaf6b SHA512 4dbda2809cb6a8d5dad072200b48695e45014fdaee873eb4e078f80dcd230ae5509c5465cc492db117eac61a072a57a90fa75b7c79a61648dd8863763a4053c0
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.16.4.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.16.4.ebuild
new file mode 100644
index 000000000000..55652bdcf792
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.16.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://cgit.kde.org/ksshaskpass.git"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}