summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-02-15 15:46:33 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-02-15 18:50:14 +0100
commitd1c6c6764f6f7e7546ba6a5ff802565d4889457a (patch)
tree7116c94b5083fe73b640d579b05e679cc50753ba /kde-plasma/ksshaskpass
parentkde-plasma/kscreenlocker: 5.24.1 version bump (diff)
downloadgentoo-d1c6c6764f6f7e7546ba6a5ff802565d4889457a.tar.gz
gentoo-d1c6c6764f6f7e7546ba6a5ff802565d4889457a.tar.bz2
gentoo-d1c6c6764f6f7e7546ba6a5ff802565d4889457a.zip
kde-plasma/ksshaskpass: 5.24.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.24.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 334ce4c7e16f..5abf430220cc 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.23.5.tar.xz 24068 BLAKE2B 42b366d66690e0bc2a0bd1abf78fc9ded0f62c71b3abd512601805ca05828449808ff87bed3dbd3cb2e421d8b50b794c207def51a73e5c0a2a53b79a51e64953 SHA512 e1bf158cc199406648afae537c73178aa5230a108371cb0d4d150849c16201d225a863c5154d52ab5b09a947671a2d91ae33dcb227d9a28c31a4d4d4f404c817
DIST ksshaskpass-5.24.0.tar.xz 24452 BLAKE2B db02d5997362c6c07949c62db3d5238731c0e1f8c06725787fe48d878f7ea74542e6faea362ddcec8b04278a4cc85c81bea7c96b0988c1b13c313f234c99a3a1 SHA512 3b8ba2fb0564aa8979ee3d9edaa03b291476fe1aeace1d75acee862a1242e9481ebb81aefcce86d5966ab6a32c5549dc198c898f4a626c6685a3abf9817477aa
+DIST ksshaskpass-5.24.1.tar.xz 24420 BLAKE2B dbd09a8d4928f739fab477adc777ec5f93e41409e66be12742b90de52b8086c262786c17dc4712fd39bd3fd2c6665a84f9c635730c2ee12947e801780b762567 SHA512 da91fab9af11e22384ef20c169827d08c5b3794bf9e8b23fe9db7e305048e32b3836a16c8f2857d52beaeb6f7bdaafe3cb7ac75e9e2e131daa19880083a1a5fd
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.24.1.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.24.1.ebuild
new file mode 100644
index 000000000000..6cc8bba6f520
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.24.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.90.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 5,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+
+ # Clean up pre-5.17.4 dirs
+ rmdir -v "${EROOT}"/etc/plasma{/startup,} 2> /dev/null
+}