summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-06-27 22:44:56 +0200
committerJohannes Huber <johu@gentoo.org>2018-06-27 22:45:24 +0200
commitad9b3995a238dd866e0e405907887ad30add40fa (patch)
tree26c0d64a118d352973220848dcd035958116e206 /kde-plasma/ksysguard/ksysguard-5.12.6.ebuild
parentdev-python/cliff-tablib: Support python3.6 (diff)
downloadgentoo-ad9b3995a238dd866e0e405907887ad30add40fa.tar.gz
gentoo-ad9b3995a238dd866e0e405907887ad30add40fa.tar.bz2
gentoo-ad9b3995a238dd866e0e405907887ad30add40fa.zip
kde-plasma: Version bump KDE Plasma 5.12.6
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'kde-plasma/ksysguard/ksysguard-5.12.6.ebuild')
-rw-r--r--kde-plasma/ksysguard/ksysguard-5.12.6.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/kde-plasma/ksysguard/ksysguard-5.12.6.ebuild b/kde-plasma/ksysguard/ksysguard-5.12.6.ebuild
new file mode 100644
index 000000000000..5e2260a85627
--- /dev/null
+++ b/kde-plasma/ksysguard/ksysguard-5.12.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Network-enabled task manager and system monitor"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="lm_sensors"
+
+DEPEND="
+ $(add_plasma_dep libksysguard '-minimal(-)')
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+RDEPEND="${DEPEND}
+ !kde-plasma/ksysguard:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package lm_sensors Sensors)
+ )
+
+ kde5_src_configure
+}