summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-02-22 12:36:12 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-02-22 12:41:28 +0100
commit5cc6d781e408461e65e00320c7e1c14dc2e38247 (patch)
tree36d373c37f8dbba7b505d8e587f395372531f462 /kde-plasma/ksysguard/ksysguard-5.8.6.ebuild
parentmedia-libs/libilbc: Add architecture definition for ppc/ppc64 (bug 610546). (diff)
downloadgentoo-5cc6d781e408461e65e00320c7e1c14dc2e38247.tar.gz
gentoo-5cc6d781e408461e65e00320c7e1c14dc2e38247.tar.bz2
gentoo-5cc6d781e408461e65e00320c7e1c14dc2e38247.zip
kde-plasma: KDE Plasma 5.8.6 version bump
Package-Manager: portage-2.3.3
Diffstat (limited to 'kde-plasma/ksysguard/ksysguard-5.8.6.ebuild')
-rw-r--r--kde-plasma/ksysguard/ksysguard-5.8.6.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/kde-plasma/ksysguard/ksysguard-5.8.6.ebuild b/kde-plasma/ksysguard/ksysguard-5.8.6.ebuild
new file mode 100644
index 000000000000..14f94fe17201
--- /dev/null
+++ b/kde-plasma/ksysguard/ksysguard-5.8.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Network-enabled task manager and system monitor"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="lm_sensors"
+
+DEPEND="
+ $(add_plasma_dep libksysguard)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+RDEPEND="${DEPEND}
+ !kde-plasma/ksysguard:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package lm_sensors Sensors)
+ )
+
+ kde5_src_configure
+}