summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-08 13:40:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-08 14:32:55 +0100
commit5e0f583660d70d633152b9639af6b52e6f690090 (patch)
tree361e6c35245cbfb031ee399a9d3d441768480d8e /kde-plasma/kwallet-pam/kwallet-pam-5.14.5.ebuild
parentdev-lang/ruby: Added sys-libs/readline to RDEPEND. (diff)
downloadgentoo-5e0f583660d70d633152b9639af6b52e6f690090.tar.gz
gentoo-5e0f583660d70d633152b9639af6b52e6f690090.tar.bz2
gentoo-5e0f583660d70d633152b9639af6b52e6f690090.zip
kde-plasma: Add KDE Plasma 5.14.5
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam/kwallet-pam-5.14.5.ebuild')
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.14.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.14.5.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.14.5.ebuild
new file mode 100644
index 000000000000..a3318b9c7b11
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.14.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KWallet PAM module to not enter password again"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ virtual/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ -DKWALLET4=0
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}