summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-02-25 15:29:30 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-25 18:23:49 +0100
commitae8c19f8d28c0946c5d5e92a32b944621d466bb6 (patch)
tree39974984dc3edd56b27110901d5e2998a600c122 /kde-plasma/kwallet-pam/kwallet-pam-5.18.2.ebuild
parentapp-crypt/qca: 2.3.0 version bump (diff)
downloadgentoo-ae8c19f8d28c0946c5d5e92a32b944621d466bb6.tar.gz
gentoo-ae8c19f8d28c0946c5d5e92a32b944621d466bb6.tar.bz2
gentoo-ae8c19f8d28c0946c5d5e92a32b944621d466bb6.zip
kde-plasma: Add KDE Plasma 5.18.2
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam/kwallet-pam-5.18.2.ebuild')
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.18.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.18.2.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.18.2.ebuild
new file mode 100644
index 000000000000..2b37bf4139b2
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.18.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.66.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ dev-libs/libgcrypt:0=
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}